[kuangbin带你飞]专题一 简单搜索-C - Catch That Cow POJ - 3278

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 108204 Accepted: 33803

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K(0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:   N  and   K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题解:

        题目的意思是牛在一个坐标K的地方,农夫在坐标N的地方,农夫有三种方式去行走,(1)N*2  (2)N+1  (3)N-1
想要最短的方式走到,显然是用宽搜的方式,但是重点来了,宽搜也是有技巧的。
        首先一定要定义一个vis来储存有没有走过这个点。这是最最必要的优化,否则会有死循环的。
        另外,有关于题目方面的优化也很重要,这道题,我可以总结出三个优化方案。没有优化剪枝,程序会非常的繁琐。
        再者,使用 qu.empty() 确实要比 qu.size() 要快上很多。
#include <iostream>
#include <queue>
using namespace std;

int N,K;

struct Node {
    int Lo,step;
    Node(int Lo = 0,int step = 0):Lo(Lo),step(step){};
};

queue<Node> qu;
int vis[200007];

int bfs(){
    qu.push(Node(N,0));

    Node t;
    while (!qu.empty()){
        t = qu.front();
        qu.pop();
        int Lo   = t.Lo;
        int step = t.step;

        if (Lo == K) break;
        if (Lo > K*2 || Lo > 200000 || Lo < 0)continue;
        if (vis[Lo])continue;

        vis[Lo] = 1;
        qu.push(Node(Lo*2,step+1));
        qu.push(Node(Lo+1,step+1));
        qu.push(Node(Lo-1,step+1));
    }

    return t.step;
}

int main()
{
    cin >> N >> K;

    if (N >= K) cout << N-K << endl;
    else {
        int ans = bfs();

        cout << ans << endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值