[kuangbin带你飞]专题1 简单搜索 C - Catch That Cow POJ - 3278

题目:

Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 101653   Accepted: 31771

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4


大致题意:一个人站在n位置,每次可以往前走1个单位,或者往后走一个单位,或者直接闪现到当前位置*2的地方。问最少需要多少步到达k位置。


思路:裸的BFS。


坑点:(至今想不明白为啥)把输出放到main就wa了,在bfs函数里面输出就A了。


#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<stack>

typedef long long ll;

using namespace std;

const int MAXN = 100000;

int n,k; 

int vis[100010];

struct node{
	int pos;
	int step;
};

node now,next;

int bfs(){
	queue<node> Q;
	now.pos = n , now.step = 0;
	vis[n] = 1;
	Q.push(now);
	
	while(!Q.empty()){
		now = Q.front();
		Q.pop();
		if(now.pos == k){
			cout<<now.step<<endl;
			return;
		} 
		
		if(now.pos-1 >= 0 && !vis[now.pos-1]){
			next.pos = now.pos - 1;
			next.step = now.step + 1;
			vis[next.pos] = 1;
			Q.push(next);
		}
		if(now.pos+1 <= MAXN && !vis[now.pos+1]){
			next.pos = now.pos + 1;
			next.step = now.step + 1;
			vis[next.pos] = 1;
			Q.push(next);
		}
		if(2*now.pos <= MAXN && !vis[now.pos*2]){
			next.pos = now.pos*2;
			next.step = now.step + 1;
			vis[next.pos] = 1;
			Q.push(next);
		}
	}	
}

int main(){
	ios::sync_with_stdio(false);
	cin>>n>>k;
	
	memset(vis,0,sizeof(vis));
	bfs();
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值