CSU-ACM 1100一二三

1100: 一二三

Submit Page      Summary      Time Limit: 1 Sec       Memory Limit: 128 Mb       Submitted: 2157       Solved: 1009    

Description

你弟弟刚刚学会写英语的一(one)、二(two)和三(three)。他在纸上写了好些一二三,可惜有些字母写错了。已知每个单词最多有一个字母写错了(单词长度肯定不会错),你能认出他写的啥吗?  

Input

第一行为单词的个数(不超过10)。以下每行为一个单词,单词长度正确,且最多有一个字母写错。所有字母都是小写的。 

Output

对于每组测试数据,输出一行,即该单词的阿拉伯数字。输入保证只有一种理解方式。 

Sample Input

3
owe
too
theee

Sample Output

1
2
3
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
	int t,a;
	char s[10];
	while(std::cin>>t)
	{
		while(t--)
		{
			cin>>s;
			a=strlen(s);
			if(a==5)
			cout<<"3"<<endl;
			else
			{
				if(s[0]=='o')
				{
					if(s[1]=='n')
					cout<<"1"<<endl;
					if(s[1]!='n')
					{
			    		if(s[2]=='e')
				    	cout<<"1"<<endl;
					}
				}
				if(s[0]=='t')
				{
					if(s[1]=='n')
				    {
				    	if(s[2]=='e')
				    	cout<<"1"<<endl;
					}
					else
					cout<<"2"<<endl;
				}
				if(s[0]!='o'&&s[0]!='t')
				{
					if(s[1]=='n')
					cout<<"1"<<endl;
					if(s[1]=='w')
					cout<<"2"<<endl;
				}
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值