根据后序和中序遍历输出先序遍历 (25 分)

本题要求根据给定的一棵二叉树的后序遍历和中序遍历结果,输出该树的先序遍历结果。

输入格式:

第一行给出正整数N(≤30),是树中结点的个数。随后两行,每行给出N个整数,分别对应后序遍历和中序遍历结果,数字间以空格分隔。题目保证输入正确对应一棵二叉树。

输出格式:

在一行中输出Preorder:以及该树的先序遍历结果。数字间有1个空格,行末不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

Preorder: 4 1 3 2 6 5 7

参考代码:

#include <bits/stdc++.h>
using namespace std;
typedef int ElementType;
typedef struct TNode *BTree;
struct TNode{
    ElementType Data;
    BTree Left;
    BTree Right;
};

int n, a[31], b[31];

void printTree(BTree root) {
    if(root) {
        cout<<" "<<root->Data;
        if(root->Left) printTree(root->Left);
        if(root->Right) printTree(root->Right);
    }
}

BTree buildTree(int l1, int r1, int l2, int r2) {

    if(l1 > r1) return NULL;
    if(l2 > r2) return NULL;

    BTree t = new TNode;
    t->Data = b[r2];
    int middle = l1;
    while(a[middle] != b[r2]) middle++;
    int leftLength = middle - l1;
    t->Left = buildTree(l1, middle-1, l2, l2+leftLength-1);
    t->Right = buildTree(middle+1, r1, l2+leftLength, r2-1);
    return t;
}

int main() {
    cin>>n;
    for(int i = 0; i < n; i++) {
        cin>>b[i];
    }
    for(int i = 0; i < n; i++) {
        cin>>a[i];
    }
    BTree root = buildTree(0, n-1, 0, n-1);
    cout<<"Preorder:";
    printTree(root);

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值