西南科技大学OJ题 above average 0706

above average

 1000(ms)

 65535(kb)

 1531 / 3045

It is said that 90% of frosh expect to be above average in their class. You are to provide a reality check.

输入

The first line of standard input contains an integer C, the number of test cases. C data sets follow. Each data set begins with an integer, N, the number of people in the class (1 <= N <= 1000). N integers follow, separated by spaces or newlines, each giving the final grade (an integer 0 <= final grade <= 100) of a student.

输出

For each case you are to output a line giving the percentage of students whose grade is above average, rounded to 3 decimal places.

样例输入

5
5 50 50 70 80 100
7 100 95 90 80 70 60 50
3 70 90 80
3 70 90 81
9 100 99 98 97 96 95 94 93 91

样例输出

40.000%
57.143%
33.333%
66.667%
55.556%
#include<stdio.h>
int main()
{
	int n;
	int a[100][1005];
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&a[i][0]);
		int sum=0;
		int avge=0;
		for(int j=1;j<=a[i][0];j++)
		{
			scanf("%d",&a[i][j]);
			sum+=a[i][j];
		}
		avge=sum/a[i][0];
		float k=0;
		for(int j=1;j<=a[i][0];j++)
		{
			if(a[i][j]>avge)
			k++;
		}
		k=k/a[i][0];
		printf("%.3f%%\n",k*100);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值