poj2503 map做法

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input
Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output
Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as “eh”.
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay
Sample Output
cat
eh
loops
Hint
Huge input and output,scanf and printf are recommended.

#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<map>
#include<vector>
using namespace std;
map<string,string>mp;
int main()
{
    int l,t;
    string s,s1,s2;
    getline(cin,s);
    l=s.length();
    while(l!=0)
    {
        t=s.find(' ',0);//从零号位查找空格
        s1.assign(s,0,t);//string &assign(const string &s,int start,int n);把字符串s中从start开始的n个字符赋给当前字符串
        s2.assign(s,t+1,l-t-1);
        mp[s2]=s1;
        getline(cin,s);
        l=s.length();
    }
    while(cin>>s)
    {
        if(mp.find(s)!=mp.end())
            cout<<mp[s]<<endl;
        else
            cout<<"eh"<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值