POJ Babelfish 2503(map,字典树)

3 篇文章 0 订阅
3 篇文章 0 订阅

Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 40265 Accepted: 17159

Description

You have just moved from Waterloo to a big city. The people here speak an   incomprehensible (费解的)   dialect (方言)  of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10   lowercase (小写字母)  letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.

Source


题意:给出单词对应关系,然后询问,输出相对应的单词

可以用map水过去

也可以用字典树



map


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <map>
using namespace std;

int main()
{
    char a[50],s[20],str[20];
    map<string,string>k;
    while(gets(a)&&a[0]!='\0')
    {
        sscanf(a,"%s%s",str,s);
        k[s]=str;
    }
    while(gets(a) && a[0]!='\0')
    {
        sscanf(a,"%s",s);
       if(k.find(s)==k.end())
       {
           printf("eh\n");
       }
       else
       {
           cout<<k[s]<<endl;
       }
    }
    return 0;
}


字典树

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
struct node
{
    int flag;
    int next[26];
}q[510000];
char s[100100][11];
int top=0;
int newnode()
{
    q[top].flag=0;
    memset(q[top].next,-1,sizeof(q[top].next));
    return top++;
}
void Inerst(int p,char s[],int l)
{
    //printf("%d\n",l);
    int i=0;
    for(;s[i]!='\0';i++)
    {
        int t=s[i]-'a';
        if(q[p].next[t]==-1)
        {
            q[p].next[t]=newnode();
        }
        p=q[p].next[t];
    }
    q[p].flag=l;
}
int query(int p,char s[])
{
    int i=0;
    for(;s[i]!='\0';i++)
    {
        int t=s[i]-'a';
        if(q[p].next[t]==-1)
        {
            return -1;
        }
        p=q[p].next[t];
    }
    return q[p].flag;
}

int main()
{
    char str[15];
    char a[50];
    int l=1;
    int k=newnode();
    //printf("%d\n",k);
    while(gets(a)&&a[0]!='\0')
    {
        sscanf(a,"%s%s",s[l],str);
        Inerst(k,str,l);
        l++;
    }
    while(gets(a)&&a[0]!='\0')
    {
        sscanf(a,"%s",str);
        int g=query(k,str);
        //printf("%d\n",g);
        if(g==-1)
        {
            printf("eh\n");
        }
        else
        {
            printf("%s\n",s[g]);
        }
    }

    return 0;
}
















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值