PAT甲级1007

1007 Maximum Subsequence Sum (25point(s))

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

题目大意:给一串数字,求最大连续子序列和。
解题思路:假设这个数组为A[],那么我们用dp[i]表示以A[i]结尾连续序列的最大和。有以下两种情况:①这个最大和的连续序列只有一个元素,即A[i]。②这个最大和的连续序列有多个元素,即从前面某处A[p]开始(p<i),一直到A[i]结尾。第①种情况最大和就是本身,第②种情况是dp[i-1]+A[i]。那么状态转移方程为:
 dp[i] = max\left \{A[i],dp[i-1]+A[i]\right \}边界为dp[0]=A[0]。

Java代码:

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {
	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		String s = br.readLine();
		int n = Integer.parseInt(s);
		s = br.readLine();
		String str[] = s.split(" ");
		int arr[] = new int[n];
		for(int i=0; i<n; i++)
		{
			arr[i] = Integer.parseInt(str[i]);
		}
		int maxn=-1, sum=0, left=0, right=n-1, temp=0;
		for(int i=0; i<n; i++)
		{
			sum+=arr[i];
			if(sum<0)
			{
				sum=0;
				temp=i+1;
			}else if(sum>maxn)
			{
				maxn = sum;
				left = temp;
				right = i;
			}
		}
		if(maxn<0) maxn=0;
		System.out.println(maxn+" "+arr[left]+" "+arr[right]);
	}
}

注意:在使用Java解题时,测试用例数据量可能会很大时,读入操作如果使用Scanner类,会出现超时的情况,因为Scanner的读入操作效率极低,在读入数据时可能就已经超时,这里推荐使用BufferedReader类,读入速度将远高于Scanner,当然也有一定的弊端,BufferReader不能直接读入数字,这里可以采用读入一行数据后再对字符串分割转换成整数数组,相比C++会较为繁琐,这也是为什么算法题目推荐使用C++而不用Java的原因。

C++代码:

#include <bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
    vector<int> A(n);
    for(int i=0; i<n; i++)
    {
        scanf("%d", &A[i]);
    }
    int sum=0, temp=0, maxn=-1, left=0, right=n-1;
    for(int i=0; i<n; i++)
    {
        sum+=A[i];
        if(sum<0){
            sum = 0;
            temp = i+1;
        }else if(sum>maxn)
        {
            maxn = sum;
            left = temp;
            right = i;
        }
    }
    if(maxn<0) maxn=0;
    printf("%d %d %d", maxn, A[left], A[right]);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值