【PAT(甲级)】1007 Maximum Subsequence Sum

Given a sequence of K integers { N1​, N2​, ..., NK​ }. A continuous subsequence is defined to be { Ni​, Ni+1​, ..., Nj​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

解题思路:

先读题,题目中的意思是找出最大连续字串的和,以及子串首末的值。所以我们就用temp来存储临时的和,max来存储全部连续子串中最大的和,tl存储temp开始时的首部,lead和teal来存储和最大子串的首尾。

因为是连续相加的,所以当temp<0时需要将temp重置为0并将tl=i+1移动到下一位(因为负数对总的和来说肯定减小,没必要加上去),而当temp>max时将temp赋值给max,tl赋值给lead,并且此时i所处的位置就是teal的值。

易错点:

1. 当所有值为负数时,输出的总和应该是0以及首尾的值(用flag来判断是否全是负数,max赋初始值为-1,只要temp>-1了说明就肯定不可能全是负数,此时将flag赋值为1,最后凭借flag只要在输出的时候把max改成0就行

例如:

输入

3

-1 -2 -3

输出:

0 -1 -3

2.  当输入中包含0,且没有大于0的数时,应输出0 0 0

(吐槽一下,我就觉得这题目有点坑,我还以为全是负数的时候输出应该和全零的情况一样呢,靠背啦,它也不说默认总和为0,有点小坑。)

代码:

#include<bits/stdc++.h>
using namespace std;
int main(){
	int K;
	cin>>K;
	vector<int> N;
	for(int i=0;i<K;i++){//按照要求读取数据 
		int temp;
		cin>>temp;
		N.push_back(temp);
	}
	int max=-1,temp=0,flag=0;
	//max初始值一定要是负数,如果是0的话,对一些含有0的非正数数据将出现答案差错 
	int lead=0,teal=K-1,tl=0;
	for(int i=0;i<K;i++){//循环累加temp 
		temp+=N[i];
		if(temp<0){//当temp小于0时说明对max的总和已经没用了,所以重置 
			temp=0;
			tl=i+1;//更改起始点 
		}
		else if(temp>max){//temp大于max时将信息赋予max,teal,lead 
			flag=1;
			max=temp;
			lead=tl;
			teal=i;
		}
	}
	if(flag)
		cout<<max<<" "<<N[lead]<<" "<<N[teal];
	else
		cout<<0<<" "<<N[0]<<" "<<N[K-1];
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值