This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1 aN1 N2 aN2 … NK aNK
where K is the number of nonzero terms in the polynomial, Ni and aNi
(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2 <N1≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
代码
#include <iostream>
int main() {
float poly[1003]={0},coe;
int exp,n1,n2,ct=0,nz=0;
scanf("%d",&n1);
for(int i=0;i<n1;i++){
scanf("%d%f",&exp,&coe);
poly[exp]=coe;
}
scanf("%d",&n2);
nz = n1 + n2;
for(int i=0;i<n2;i++){
scanf("%d%f",&exp,&coe);
if(poly[exp]) nz--;
poly[exp]= poly[exp] + coe;
if(poly[exp] == 0){
nz--;
}
}
printf("%d",nz);
if(nz){
printf(" ");
}
ct = 0;
for(int i=1002;i>=0;i--){
if(poly[i] !=0 ){
printf("%d %.1f",i,poly[i]);
ct++;
}else{
continue;
}
if(ct < nz){
printf(" ");
}
if(ct == nz){
printf("\n");
break;
}
}
return 0;
}