PAT | A 1002 for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a​N1 N2 aN2 … NK aNK
​​

where K is the number of nonzero terms in the polynomial, Ni and aN​i
​​
​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NK<⋯<N2 <N1≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

代码

#include <iostream>

int main() {
	float poly[1003]={0},coe;
	int exp,n1,n2,ct=0,nz=0;

	scanf("%d",&n1);
	for(int i=0;i<n1;i++){
		scanf("%d%f",&exp,&coe);
		poly[exp]=coe;
	}
	scanf("%d",&n2);
	nz = n1 + n2;
	for(int i=0;i<n2;i++){
		scanf("%d%f",&exp,&coe);
		if(poly[exp]) nz--;
		poly[exp]= poly[exp] + coe;
		if(poly[exp] == 0){
			nz--;
		}
	}
	printf("%d",nz);
	if(nz){
		printf(" ");
	}
	ct = 0;
	for(int i=1002;i>=0;i--){
		if(poly[i] !=0 ){
			printf("%d %.1f",i,poly[i]);
			ct++;
		}else{
			continue;
		}
		if(ct < nz){
			printf(" ");
		}
		if(ct == nz){
			printf("\n");
			break;
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值