POJ 2527 Polynomial Remains(多项式除法)

Description

Given the polynomial
a(x) = an xn + … + a1 x + a0,

compute the remainder r(x) when a(x) is divided by xk+1.
Input

The input consists of a number of cases. The first line of each case specifies the two integers n and k (0 <= n, k <= 10000). The next n+1 integers give the coefficients of a(x), starting from a0 and ending with an. The input is terminated if n = k = -1.
Output

For each case, output the coefficients of the remainder on one line, starting from the constant coefficient r0. If the remainder is 0, print only the constant coefficient. Otherwise, print only the first d+1 coefficients for a remainder of degree d. Separate the coefficients by a single space.

You may assume that the coefficients of the remainder can be represented by 32-bit integers.
Sample Input

5 2
6 3 3 2 0 1
5 2
0 0 3 2 0 1
4 1
1 4 1 1 1
6 3
2 3 -3 4 1 0 1
1 0
5 1
0 0
7
3 5
1 2 3 4
-1 -1
Sample Output

3 2
-3 -1
-2
-1 2 -3
0
0
1 2 3 4
Source

Alberta Collegiate Programming Contest 2003.10.18

思路:
进行多项式除法,求其余数,从正面考虑,由高次项向底次项进行计算,人脑好计算,但编码不好实现,所以采用由底次向高次计算,总是消除最低次那项,然后高项不难理解就是a[i-k]=a[i-k]-a[i];低项自然便为了0;依次类推,当项数小于k的时候就停止运算,然后a数组中剩余的就是结果。
ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<vector>
#include<set>
#include<map>
#include<queue>
#include<ctype.h>
#include<stack>
#include<math.h>
#include <string>
#include<algorithm>
using namespace std;

typedef unsigned long long ULL;

int main()
{
    ios::sync_with_stdio(false);cin.tie(0);

    int a[10005];
    int n,k;
    while(cin>>n>>k&&n>=0)
    {
        for(int i=0;i<=n;i++)
            cin>>a[i];
        for(int i=n;i>=k;i--)
            if(a[i])
            {
                a[i-k]=a[i-k]-a[i];
                a[i]=0;
            }
        while(n>=0&&!a[n])
            n--;
        if(n<0)
            printf("0");
        for(int i=0;i<=n;i++)
            cout<<a[i]<<" ";
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值