POJ 2527 Polynomial Remains 多项式运算

Polynomial Remains
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1236 Accepted: 700

Description

Given the polynomial 
a(x) = a n x n + ... + a 1 x + a 0,

compute the remainder r(x) when a(x) is divided by x k+1.

Input

The input consists of a number of cases. The first line of each case specifies the two integers n and k (0 <= n, k <= 10000). The next n+1 integers give the coefficients of a(x), starting from a0 and ending with an. The input is terminated if n = k = -1.

Output

For each case, output the coefficients of the remainder on one line, starting from the constant coefficient r0. If the remainder is 0, print only the constant coefficient. Otherwise, print only the first d+1 coefficients for a remainder of degree d. Separate the coefficients by a single space. 

You may assume that the coefficients of the remainder can be represented by 32-bit integers. 

Sample Input

5 2
6 3 3 2 0 1
5 2
0 0 3 2 0 1
4 1
1 4 1 1 1
6 3
2 3 -3 4 1 0 1
1 0
5 1
0 0
7
3 5
1 2 3 4
-1 -1

Sample Output

3 2
-3 -1
-2
-1 2 -3
0
0
1 2 3 4

Source

Alberta Collegiate Programming Contest 2003.10.18

AC代码

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int main(){
    int n,k;
    int my[10000+10];
    while(cin>>n>>k){
        if(n==-1&&k==-1)break;
        for(int i=0;i<=n;i++)cin>>my[i];
        ///for(int i=n;i>0;--i)cout<<my[i]<<"x^"<<i<<'+';
        ///cout<<my[0]<<'\12';
        for(int i=n;i>=k;--i){
            if(my[i]==0)continue;
            my[i-k]=my[i-k]-my[i];
            my[i]=0;
        }
        int len=n;
        while(len>=0&&!my[len])len--;
        for(int i=0;i<len;++i)cout<<my[i]<<' ';
        cout<<my[len]<<'\12';
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值