Sort II - Partition

Partition

Quick sort is based on the Divide-and-conquer approach. In QuickSort(A, p, r), first, a procedure Partition(A, p, r) divides an array A[p..r] into two subarrays A[p..q-1] and A[q+1..r] such that each element of A[p..q-1] is less than or equal to A[q], which is, inturn, less than or equal to each element of A[q+1..r]. It also computes the index q.

In the conquer processes, the two subarrays A[p..q-1] and A[q+1..r] are sorted by recursive calls of QuickSort(A, p, q-1) and QuickSort(A, q+1, r).

Your task is to read a sequence A and perform the Partition based on the following pseudocode:

Partition(A, p, r)
1 x = A[r]
2 i = p-1
3 for j = p to r-1
4     do if A[j] <= x
5        then i = i+1
6            exchange A[i] and A[j] 
7 exchange A[i+1] and A[r]
8 return i+1

 

Note that, in this algorithm, Partition always selects an element A[r] as a pivot element around which to partition the array A[p..r].

 

Input

The first line of the input includes an integer n, the number of elements in the sequence A.

In the second line, Ai (i = 1, 2, ..., n), elements of the sequence are given separated by space characters.

Output

Print the sorted sequence. Two contiguous elements of the sequence should be separated by a space character. The element which is selected as the pivot of the partition should be indicated by [  ].

Constraints

  • 1 ≤ n ≤ 100,000
  • 0 ≤ Ai ≤ 100,000

Sample Input 1

12
13 19 9 5 12 8 7 4 21 2 6 11

Sample Output 1

9 5 8 7 4 2 6 [11] 21 13 19 12

本题注意:要用define 不要用const 要用scanf 不要cin因为前者比后者更快

本题就在边界上 所以要尽量快

#include <bits/stdc++.h>
using namespace std;
#define MAX 100000
int A[MAX],n;
int partition(int p,int r)
{
	int x,i,j,t;
	x = A[r];
	i = p - 1;
	for(j = p;j < r;j++)
	{
		if(A[j] <= x)
		{
			i++;
			t = A[i]; A[i] = A[j]; A[j] = t;
		}
	}
	t = A[i + 1]; A[i + 1] = A[r]; A[r] = t;
	return i + 1;
}
int main(int argc, char const *argv[])
{
	int i,q;
	scanf("%d",&n);
	for(i = 0;i < n;i++)
	{
		scanf("%d",&A[i]);
	}
	q = partition(0,n - 1);
	for(i = 0; i < n;i++)
	{
		if(i) printf(" ");
		if(i == q) 
			{
				printf("[");
			}
				printf("%d",A[i] );
			
		if(i == q) printf("]");
	}
	printf("\n");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值