HDU - 1896 Stones(优先队列)

5 篇文章 0 订阅
3 篇文章 0 订阅

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first. 

 

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

 

Output

Just output one line for one test case, as described in the Description. 

Sample Input

2
2
1 5
2 4
2
1 5
6 6

 

Sample Output

11
12

 

题目大意:x轴从左向右有n个石头,每个石头有两个值pi表示位置,id表示能够往前扔的最大距离,开始时从原点开始走,遇到奇数个石头往前扔他,遇到偶数个石头放在原地不动,当多个石头位置相同时,优先遇到id较小的石头

解题思路:使用优先队列来做,遇到奇数个石头取出栈顶元素,更新栈顶元素的pi值,将栈顶元素出栈,将更新后的元素进栈,遇到偶数个石头,直接出栈,最后输出结果即可,

AC代码:

#include<iostream>
#include<queue>
using namespace std;
struct node{
	int pi;
	int id;
	friend bool operator < (node a,node b)
	{
		if(a.pi==b.pi)
			return a.id>b.id;//id小的优先级大 
		else
			return a.pi>b.pi;//pi小的优先级大 
	}
}a; 
priority_queue<node> q;//优先队列,优先级大的先出栈 
int main()
{
	int t,n;
	cin>>t;
	while(t--)
	{
		while(!q.empty()) //如果队列q不为空 
			q.pop();
		cin>>n;
		for(int i=0;i<n;i++)
		{
			cin>>a.pi>>a.id;
			q.push(a);
		}
		int k=1;
		while(!q.empty())
		{
			if(k&1)//奇数石头 
			{
				a=q.top();
				q.pop();
				a.pi=a.pi+a.id;
				q.push(a);
			}
			else
				q.pop();
			k++;
		}
		cout<<a.pi<<endl; 
	} 
	return 0; 
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值