LightOJ - 1141 Number Transformation

In this problem, you are given an integer number s. You can transform any integer number A to another integer number B by adding x to A. This x is an integer number which is a prime factor of A (please note that 1 and A are not being considered as a factor of A). Now, your task is to find the minimum number of transformations required to transform sto another integer number t.

 

 

Input

Input starts with an integer T (≤ 500), denoting the number of test cases.

Each case contains two integers: s (1 ≤ s ≤ 100) and t (1 ≤ t ≤ 1000).

 

Output

For each case, print the case number and the minimum number of transformations needed. If it's impossible, then print -1.

 

Sample Input

2

6 12

6 13

 

Sample Output

Case 1: 2

Case 2: -1

题目大意:给两个数s,t,然后s加上他的一个质因子形成另一个数,在让这个新的数加上他的质因子形成另一个数,输出最少的这个过程是s==t,得不到就输出-1

解题思路:bfs求解

AC代码:

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
bool vis[1100];
int prime[1100];
int s,t;
struct node{
	int x;
	int step;
}; 
void get_prime()//素数打表 
{
	for(int i=2;i*i<=1100;i++)
	{
		if(!prime[i])
		{
			for(int j=i*i;j<=1100;j+=i)
				prime[j]=1;
		}
	}
}
int bfs()
{
	memset(vis,0,sizeof(vis));
	queue<node>q;
	node now,nextt;
	now.x=s;
	now.step=0;
	q.push(now);
	while(!q.empty())
	{
		now=q.front();
		q.pop();
		if(now.x==t)
			return now.step;
		for(int i=2;i<now.x;i++)
		{
			if(now.x%i==0&&!prime[i]&&now.x+i<=t&&!vis[now.x+i])
			{
				nextt.x=now.x+i;
				nextt.step=now.step+1;
				vis[nextt.x]=1;
				q.push(nextt);
			}
		}
	}
	return -1;
}
int main()
{
	int T,k=1;
	get_prime(); 
	cin>>T;
	while(T--)
	{
		cin>>s>>t;
		printf("Case %d: %d\n",k++,bfs());
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sigma函数是指一个数字的所有因子之和。给定一个数字n,需要求出有多少个数字的Sigma函数是偶数。\[2\] 为了解决这个问题,可以先筛选出n范围内的素数(范围在10^6即可),然后对n进行素因子分解。对于每个因子,如果它的Sigma函数中连乘的每一项都是偶数,那么整个Sigma函数就是偶数。具体实现中,可以判断每个因子的平方根是否为偶数,如果是偶数,则减去(平方根+1)/2。\[1\] 另外,还可以使用O(1)的做法来解决这个问题。根据观察,所有的完全平方数及其两倍的值都会导致Sigma函数为偶数。因此,可以直接计算n的平方根,然后减去(平方根+1)/2即可得到结果。\[3\] #### 引用[.reference_title] - *1* [Sigma Function](https://blog.csdn.net/PNAN222/article/details/50938232)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [【LightOJ1336】Sigma Function(数论)](https://blog.csdn.net/qq_30974369/article/details/79009498)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值