POJ - 2387 Til the Cows Come Home (链式前向星+优先队列)

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

 

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

 

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

 

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

 

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

 

题目大意:有1 2 3 ....n,n个顶点,然后是t组数据,每组u,to,w,表示顶点u到顶点to的距离,输出顶点1到顶点n之间的最短路径

解题思路:dijkstra算法求解最短路径,如果题目所给边数过大二维数组就储存不下了,使用链式前向星存图,每一次在找最短的那个顶点时使用优先队列来找,从而达到空间和时间优化的效果

AC代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<queue>
using namespace std;

const int maxn=1e4;
const int INF=0x3f3f3f3f;

struct node{
	int to;
	int w;
	int next;
}e[maxn];

int head[maxn],cnt,n;
int d[maxn],vis[maxn];

void add(int u,int to,int w)
{
	e[cnt].to=to;
	e[cnt].w=w;
	e[cnt].next=head[u];
	head[u]=cnt++;
}

struct test{
	int u;
	int dis;
	bool friend operator <(test a,test b)
	{
		return a.dis>b.dis;
	}
}term,nextt;

void dijkstra_heap(int u)
{
	d[u]=0;
	priority_queue<test> q;
	term.u=u;
	term.dis=d[u];
	q.push(term);
	while(!q.empty())
	{
		term=q.top();//到起点距离最短还没有确定的那个点出队 
		q.pop();
		vis[term.u]=1;//当前这个节点的最短距离确定标记为1 
		for(int i=head[term.u];~i;i=e[i].next)
		{
			int to=e[i].to;
			int w=e[i].w;
			if(!vis[to]&&d[term.u]+w<d[to])
			{
				d[to]=d[term.u]+w;
				nextt.u=to;
				nextt.dis=d[to];
				q.push(nextt);
			}
		}
	}
}
int main()
{
	int t,u,to,w;
	memset(head,-1,sizeof(head));
	memset(d,INF,sizeof(d));
	scanf("%d%d",&t,&n);
	for(int i=0;i<t;i++)
	{
		scanf("%d%d%d",&u,&to,&w);
		add(u,to,w);
		add(to,u,w);
	}
	dijkstra_heap(1);
	cout<<d[n]<<endl;
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值