poj 2387(Dijkstra优先队列优化)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input

  • Line 1: Two integers: T and N

  • Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
    Output

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output

90
Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

大致题意:有多组数据,每组数据首先输入T和n,表示有T条边和n个点,接下来输入每两个点的编号和连接他们的一条边的长度。问从1到n的最短路程。保证1到n有一条通路。
(注意有多重边)
思路:Dijkstra求最短路

代码如下

代码1

#include<iostream>
#include<algorithm>
#include<string>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>

using namespace std;

const int INF=0x3f3f3f3f;
const int maxn=1005;
int maps[maxn][maxn];//存两点间的距离
int dis[maxn];//表示源点到该点的最短路 
int n;//节点数 

struct node
{
    int num;
    int dis;
    friend bool operator <(node a,node b)
    {
        if(a.dis==b.dis) return a.num>b.num;
        return a.dis>b.dis;
    }
};
priority_queue<node> que;//用优先队列优化

void init()
{
    for(int i=1;i<=n;i++)
    for(int j=1;j<=n;j++)
    maps[i][j]=INF;
}
void Dijkstra(int s)
{
    int vis[maxn];//表示该点是否已经访问过 
    for(int i=1;i<=n;i++)
    dis[i]=INF;
    memset(vis,0,sizeof(vis));

    dis[s]=0;
    node u;
    u.dis=0;
    u.num=s;
    que.push(u);
    while(!que.empty())
    {
        node u=que.top();
        que.pop();
        int x=u.num;

        if(vis[x])
            continue;
        vis[x]=1;   

        for(int i=1;i<=n;i++)
        {
            if(!vis[i]&&dis[i]>dis[u.num]+maps[u.num][i])
            {
                dis[i]=dis[u.num]+maps[u.num][i];
                node v;
                v.num=i;
                v.dis=dis[i];
                que.push(v);
            }
        }
    }
    printf("%d\n",dis[n]);
 } 

 int main()
 {

    int T,x,y,D;
    while(scanf("%d%d",&T,&n)!=EOF)
    {
        init();
        for(int i=1;i<=T;i++)
        {
            scanf("%d%d%d",&x,&y,&D);
            if(D<maps[x][y])//有多重边,记录最短的一条即可
            {
             maps[y][x]=maps[x][y]=D;
            }
         }
         Dijkstra(1);
     }
     return 0;
 }

代码2

#include<stdio.h>
#include<string.h>
#include<stdio.h>
#include<cstdio>
#include<iostream>
using namespace std;

const int INF=0x3f3f3f3f;
const int maxn=1005;
int maps[maxn][maxn];
int vis[maxn];//表示该点是否已经遍历过 
int dis[maxn];//表示源点到该点的最短路 
int n;//节点数 
void Dijkstra(int s,int e)
{

    memset(dis,INF,sizeof(dis));
    dis[s]=0;
    for(int i=1;i<=n;i++)
    {
        int mini=INF;
        int k=-1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&dis[j]<mini)
            {
                k=j;
                mini=dis[j];
            }
        }
        vis[k]=1;
        if(k==e)
        {
            printf("%d\n",dis[k]);
            return;
        }
        for(int j=1;j<=n;j++)
        {
            if(!vis[j])
            {
                dis[j]=min(dis[k]+maps[k][j],dis[j]);
            }
        }
    }
 } 

 int main()
 {

    int T,x,y,D;

    while(scanf("%d%d",&T,&n)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        memset(maps,INF,sizeof(maps));
        for(int i=1;i<=T;i++)
        {

            scanf("%d%d%d",&x,&y,&D);
            if(D<maps[x][y])
            {
             maps[x][y]=D;
             maps[y][x]=D;
            }
         }
         Dijkstra(1,n);
     }
     return 0;
 }
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值