Problem Description
已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。
Input
输入数据有多组,输入T,代表有T组数据。每组数据包括两个长度小于50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。
Output
输出二叉树的深度。
Example Input
2 dbgeafc dgebfca lnixu linux
Example Output
4 3
代码:
#include <bits/stdc++.h>
#include <string.h>
using namespace std;
int cnt, k, n;
char a[51], b[51];
struct node
{
char data;
struct node *l, *r;
};
struct node *create(char a[], char b[], int n)
{
struct node *root;
root = (struct node*)malloc(sizeof(struct node));
if(n<=0)
return NULL;
else
{
root->data = b[n-1];
char *p;
for(p=a; p!='\0'; p++)
{
if(*p == b[n-1])
break;
}
int t = p - a;
root->l = create(a, b, t);
root->r = create(a+t+1, b+t, n-t-1);
return root;
}
}
int deep(struct node *root)
{
int d = 0;
if(root)
{
int l1=deep(root->l);
int l2=deep(root->r);
if(l1>l2)
d=l1+1;
else d=l2+1;
}
return d;
}
int main()
{
int t;
cin >> t;
while(t--)
{
scanf("%s", a);
scanf("%s", b);
int n = strlen(a);
struct node *root;
root = create(a, b, n);
deep(root);
printf("%d\n", deep(root));
}
return 0;
}
#include <string.h>
using namespace std;
int cnt, k, n;
char a[51], b[51];
struct node
{
char data;
struct node *l, *r;
};
struct node *create(char a[], char b[], int n)
{
struct node *root;
root = (struct node*)malloc(sizeof(struct node));
if(n<=0)
return NULL;
else
{
root->data = b[n-1];
char *p;
for(p=a; p!='\0'; p++)
{
if(*p == b[n-1])
break;
}
int t = p - a;
root->l = create(a, b, t);
root->r = create(a+t+1, b+t, n-t-1);
return root;
}
}
int deep(struct node *root)
{
int d = 0;
if(root)
{
int l1=deep(root->l);
int l2=deep(root->r);
if(l1>l2)
d=l1+1;
else d=l2+1;
}
return d;
}
int main()
{
int t;
cin >> t;
while(t--)
{
scanf("%s", a);
scanf("%s", b);
int n = strlen(a);
struct node *root;
root = create(a, b, n);
deep(root);
printf("%d\n", deep(root));
}
return 0;
}