Problem Description
冒泡排序和快速排序都是基于"交换"进行的排序方法,你的任务是对题目给定的N个(长整型范围内的)整数从小到大排序,输出用冒泡和快排对这N个数排序分别需要进行的数据交换次数。
Input
连续多组输入数据,每组数据第一行给出正整数N(N ≤ 10^5),随后给出N个整数,数字间以空格分隔。
Output
输出数据占一行,代表冒泡排序和快速排序进行排序分别需要的交换次数,数字间以1个空格分隔,行末不得有多余空格。
Example Input
8 49 38 65 97 76 13 27 49
Example Output
15 9
注意:数据相等时不交换。
code:
#include <bits/stdc++.h>
using namespace std;
int n, a[100001], b[100001], cnt, ct;
void kp(int a[], int l, int r)
{
int i, j, k;
i = l, j = r, k = a[l];
if(i > j)
return ;
while(i < j)
{
while(i < j && a[j] >= k)
j--;
if(a[i] != a[j])
a[i] = a[j],ct++;
while(i < j && a[i] <= k)
i++;
if(a[j]!=a[i])
a[j] = a[i],ct++;
}
a[j] = k;
kp(a, l, j-1);
kp(a, j+1, r);
}
void mp(int a[])
{
int i, j;
for(j = 0; j < n; j++)
{
for(i = 0; i < n-j-1; i++)
{
if(a[i]>a[i+1])
{
int t;
t = a[i];
a[i] = a[i+1];
a[i+1] = t;
cnt++;
}
}
}
}
int main()
{
while(cin >> n)
{
for(int i = 0; i < n; i++)
{
cin >> a[i];
b[i] = a[i];
}
cnt = 0, ct = 0;
kp(a, 0, n-1);
mp(b);
cout << cnt << " " << ct << endl;
}
return 0;
}