救基友记2

Time Limit: 1000 ms Memory Limit: 65536 KiB


  • Problem Description

    屌丝WP的好基友CZ又被妖鬼给抓走了(CZ啊,CZ….怎么说你好呢….吃着锅里想着碗里),为了求出CZ,他只好去求高富帅RQ, RQ给WP出了到题目说只要你能解决这道题目,他就答应帮屌丝WP去解救好基友CZ。题目描述如下:
    给你一个字符串s,长度小于1000,让你找出该字符串所包含的所有子串”cRazY” 或者”CraZy”,并将找出的子串的大写字母变成小写字母,小写字母变成大写字母,然后输出该字符串。
    “好基友,一被子” 你作为WP的好基友,能帮他解决这个问题吗?

  • Input

    第1行是一个整数T,表示测试数据的个数(1<=T<=10)。接下来有T组测试数据。
    每组测试数据包括包括一个字符串s

  • Output

    输出T行,表示转换后的字符串

  • Sample Input

2

abjbjhcRazYdcRazYCraZy
bbbnnnbbn
  • Sample Output

abjbjhCrAZydCrAZycRAzY
bbbnnnbbn

import java.util.Scanner;
class Trans{
    StringBuffer s;
    Trans(StringBuffer s){
        this.s = s;
    }
    void fun(){
        String c1 = "cRazY";
        String c2 = "CraZy";
        String c3 = "CrAZy";
        String c4 = "cRAzY";
        int index;
        while((index = s.indexOf(c1, 0))!=-1)
        {
            s = s.replace(index, index+5, c3);
        }
        while((index = s.indexOf(c2, 0))!=-1){
            s = s.replace(index, index+5, c4);
        }
        System.out.println(s);
    }
}
public class Main {
    public static void main(String[] args){
        Scanner input = new Scanner(System.in);
        int T = input.nextInt();
        while(T-->0){
            String s = input.next();
            StringBuffer str = new StringBuffer(s);
            Trans p = new Trans(str);
            p.fun();
        }
        input.close();
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值