二分——Aggressive cows 愤怒的牛

问题 A: Aggressive cows 愤怒的牛

时间限制: 5 Sec  内存限制: 64 MB
提交: 12  解决: 10
[提交][状态][讨论版][命题人:add_cy]

题目描述

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

农夫 John 建造了一座很长的畜栏,它包括N (2 <= N <= 100,000)个隔间,这些小隔间依次编号为x1,...,xN (0 <= xi <= 1,000,000,000). 但是,John的C (2 <= C <= N)头牛们并不喜欢这种布局,而且几头牛放在一个隔间里,他们就要发生争斗。为了不让牛互相伤害。John决定自己给牛分配隔间,使任意两头牛之间的最小距离尽可能的大,那么,这个最大的最小距离是什么呢

输入

* Line 1: Two space-separated integers: N and C * Lines 2..N+1: Line i+1 contains an integer stall location, xi

第一行:空格分隔的两个整数N和C

第二行---第N+1行:i+1行指出了xi的位置

输出

* Line 1: One integer: the largest minimum distance

第一行:一个整数,最大的最小值

样例输入

5 3
1
2
8
4
9

样例输出

3



(把牛放在1,4,8这样最小距离是3 )

贪心+二分

最大值最小(最小值最大)可用二分法解决

1.对牛舍的位置x进行排序

2.把第一头牛放在x0

3.如果把第i头牛放入了xj间牛舍,那么第i+1头牛就要放入满足xj+d<=xk的最小牛舍xk中,保证相邻两头牛之间的距离>=d

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<queue>
using namespace std;
int n,c,x[100005];
int judge(int d)//判断距离为d时能否放下c头牛
{
    int num=1;
    int temp=x[0]+d;
    for(int i=1;i<n;i++)
    {
        if(x[i]<temp)continue;//间距<d,继续查找
        temp=x[i]+d;//如果间距>=d,更新下一个牛舍的要求位置
        num++;//放下一头牛
    }
    if(num>=c)return 1;//能放下c头牛
    return 0;//不能放下c头牛
}
int main()
{
    cin>>n>>c;
    for(int i=0;i<n;i++)
        cin>>x[i];
    sort(x,x+n);//从小到大排序
    int l=0,r=x[n-1]-x[n];//r表示最大距离
    while(l<=r)
    {
        int mid=(l+r)/2;//mid=l+r>>1;mid二分距离
        if(judge(mid))l=mid+1;//如果所求距离d>=mid,增大试探
        else r=mid-1;//如果所求答案d<mid,减小试探
    }
    cout<<r<<endl;
    return 0;
}

 

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值