经典二分搜索题目001:Aggressive cows解答

总时间限制: 

1000ms

 

内存限制: 

65536kB

描述

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

输入

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

输出

* Line 1: One integer: the largest minimum distance

样例输入

5 3
1
2
8
4
9

样例输出

3

提示

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

来源

USACO 2005 February Gold

 

这是一个经典的二分搜索问题,解题的思路是直接枚举这个最大的最小距离,另外需要注意二分搜所的实现细节,如果不容易确定边界,最后输出的结果可以尝试判断mid-1,mid+1,left,right。代码

#include <iostream>
#include <algorithm>
#define N 100000

bool judge(int arr[], int n, int c,int distance) {
	int x = arr[0];
	int count = 1;
	for (int i = 1; i < n; i++) {
		if (arr[i] - x >= distance) {
			x = arr[i];
			count++;
		}
	}
	
	return count >= c;
	
}

int main() 
{
	int arr[N];
	int n, c;
	std::cin >> n >> c;
	for (int i = 0; i < n; i++)
		std::cin >> arr[i];
	std::sort(arr, arr + n);
	int left = 1;
	int right = arr[n - 1] - arr[0];
	int mid;
	while (left <= right) {
		mid = left + (right - left) / 2;
		if (judge(arr, n, c, mid)) {
			left = mid + 1;
		}
		else
			right = mid - 1;
	}

	std::cout << right << std::endl;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值