2018hdu杭电多校第五场 hdu6354 Everything Has Changed(几何)

11 篇文章 0 订阅
9 篇文章 0 订阅

Everything Has Changed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 725    Accepted Submission(s): 418
Special Judge

 

Problem Description

Edward is a worker for Aluminum Cyclic Machinery. His work is operating mechanical arms to cut out designed models. Here is a brief introduction of his work.
Assume the operating plane as a two-dimensional coordinate system. At first, there is a disc with center coordinates (0,0) and radius R. Then, m mechanical arms will cut and erase everything within its area of influence simultaneously, the i-th area of which is a circle with center coordinates (xi,yi) and radius ri (i=1,2,⋯,m). In order to obtain considerable models, it is guaranteed that every two cutting areas have no intersection and no cutting area contains the whole disc.
Your task is to determine the perimeter of the remaining area of the disc excluding internal perimeter.
Here is an illustration of the sample, in which the red curve is counted but the green curve is not.

Input

The first line contains one integer T, indicating the number of test cases.
The following lines describe all the test cases. For each test case:
The first line contains two integers m and R.
The i-th line of the following m lines contains three integers xi,yi and ri, indicating a cutting area.
1≤T≤1000, 1≤m≤100, −1000≤xi,yi≤1000, 1≤R,ri≤1000 (i=1,2,⋯,m).

Output

For each test case, print the perimeter of the remaining area in one line. Your answer is considered correct if its absolute or relative error does not exceed 10−6.
Formally, let your answer be a and the jury's answer be b. Your answer is considered correct if |a−b|max(1,|b|)≤10−6.

Sample Input

1

4 10

6 3 5

10 -4 3

-2 -4 4

0 9 1

Sample Output

81.62198908430238475376


题意:算圆盘被多个小圆切割后的周长

题解:注意切割区域两两不相交,则不同切割区域不会相互影响。枚举每个与圆盘相交的切割区域,计算互相被包含的圆周长度即可。用两次余弦定理 注意内切的加上 外切的无视。

PS:杭电 刚开始想用longdouble,管理员说环境不够新不能用long double

代码:

// hdu6354
#include <bits/stdc++.h>
using namespace std;
const double PI = acos(-1.0);

double dis(int a, int b, int c, int d) {
    return sqrt((a-c)*(a-c) + (b-d)*(b-d));
}

int main() {
    int t, n;
    double x = 0, y = 0, r, u, v, w, ans, bc, sc;
    scanf("%d", &t);
    while (t--) {
        scanf("%d%lf", &n, &r);
        bc = ans = 2 * PI * r;
        while (n--) {
            scanf("%lf%lf%lf", &u, &v, &w);
            sc = 2 * PI * w;
            double d = dis(x,y,u,v);
            if (d == r + w || d > r + w || d + w < r) {
                continue;
            } else if (d + w == r) {
                ans += sc;
            } else {
                double ang1 = 2*acos((d*d+r*r-w*w)/(2*d*r));
                double ang2 = 2*acos((w*w+d*d-r*r)/(2*d*w));
                ans -= ang1/(2*PI)*bc; 
                ans += ang2/(2*PI)*sc;
            }
        }
        printf("%.15lf\n", ans);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值