【模拟+数学】2018 hdu多校第五场 1005 Everything Has Changed

Everything Has Changed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3444    Accepted Submission(s): 909
Special Judge

 

Problem Description

Edward is a worker for Aluminum Cyclic Machinery. His work is operating mechanical arms to cut out designed models. Here is a brief introduction of his work.
Assume the operating plane as a two-dimensional coordinate system. At first, there is a disc with center coordinates (0,0) and radius R. Then, m mechanical arms will cut and erase everything within its area of influence simultaneously, the i-th area of which is a circle with center coordinates (xi,yi) and radius ri (i=1,2,⋯,m). In order to obtain considerable models, it is guaranteed that every two cutting areas have no intersection and no cutting area contains the whole disc.
Your task is to determine the perimeter of the remaining area of the disc excluding internal perimeter.
Here is an illustration of the sample, in which the red curve is counted but the green curve is not.

 

 

Input

The first line contains one integer T, indicating the number of test cases.
The following lines describe all the test cases. For each test case:
The first line contains two integers m and R.
The i-th line of the following m lines contains three integers xi,yi and ri, indicating a cutting area.
1≤T≤1000, 1≤m≤100, −1000≤xi,yi≤1000, 1≤R,ri≤1000 (i=1,2,⋯,m).

 

 

Output

For each test case, print the perimeter of the remaining area in one line. Your answer is considered correct if its absolute or relative error does not exceed 10−6.
Formally, let your answer be a and the jury's answer be b. Your answer is considered correct if |a−b|max(1,|b|)≤10−6.

Sample Input

1

4 10

6 3 5

10 -4 3

-2 -4 4

0 9 1

 

Sample Output

81.62198908430238475376

Statistic | Submit | Clarifications | Back

 

注意全包含和不包含不算

只要内切和部分包含

特别注意如果贴上去的圆的半径大于原来圆的时候,反三角函数算的是较小角,要判一下

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
const double pi=acos(-1.0);
double dis(double x1,double y1,double x2,double y2)
{
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int main()
{
    int t,i,m,j;
    double R,xi,yi,ri,C,c,x,h,xh,q1,q2,aa,bb;
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            scanf("%d%lf",&m,&R);
            C=2*pi*R;
            for(i=1;i<=m;i++)
            {
                scanf("%lf%lf%lf",&xi,&yi,&ri);
                xi=abs(xi);
                yi=abs(yi);
                ri=abs(ri);
                if(dis(0,0,xi,yi)+ri>=R&&dis(0,0,xi,yi)-ri<R)
                {
                    x=dis(0,0,xi,yi);
                    xh=(R*R-ri*ri+x*x)/(x*2.0);
                    h=sqrt(ri*ri-(xh-x)*(xh-x));
                    q1=asin(h/ri);
                    q2=asin(h/R);
                    if(xh>x) aa=2*pi*ri-2*q1*ri;
                    else aa=2*q1*ri;
                    if(xh<0) bb=2*pi*R-2*q2*R;
                    else bb=2*q2*R;
                    C=C-bb+aa;
                }
            }
            printf("%.14f\n",C);
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值