hdu2852(权值树状数组)

Problem Description For the k-th number, we all should be very
familiar with it. Of course,to kiki it is also simple. Now Kiki meets
a very similar problem, kiki wants to design a container, the
container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which
greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it,
can you help her to solve this problem?

Input Input some groups of test data ,each test data the first number
is an integer m (1 <= m <100000), means that the number of operation
to do. The next m lines, each line will be an integer p at the
beginning, p which has three values: If p is 0, then there will be an
integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated
that delete the element e from the container

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k
<10000),means the inquiries, the element is greater than a, and the
k-th larger number.

Output For each deletion, if you want to delete the element which does
not exist, the output “No Elment!”. For each query, output the
suitable answers in line .if the number does not exist, the output
“Not Find!”.

Sample Input
5 0 5 1 2 0 6 2 3 2 2 8 1 7 0 2 0 2 0 4 2 1 1 2 1 2 2 1 3 2 1 4

Sample Output
No Elment!
6
Not Find!
2
2
4
Not Find!

题目大意:
一个容器里面有三种操作
1 向集合中增加一个数
2 删除集合中的一个数
3 查询集合中第k个比a大的数

思路:
用权值树状数组或者权值线段树维护,题目的数据范围也比较小,不需要离散也不需要longlong
难点就是在于查询,所以用到二分的思想,树状数组维护的是前缀和(前面数字出现过的次数),求getsum(mid),与第k大相比较,k大于getsum(mid)则说明第k大在左半边区间,否则在右半边区间。最后就是,查询第k个比a大的数其实就是 查询[1,n]区间内的第getsum(k)+a 个数。
明显,用树状数组 比 用线段树维护要简单点


代码:
查询时如果我不用maxn-1就wa,不知道为什么

#include <bits/stdc++.h>

using namespace std;

const int maxn=100000+50;
typedef long long ll;
int t,n,q,e,l,k,x;
ll tree[maxn];
ll a[maxn];
int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int k)
{
    while(x<maxn)
    {
        tree[x]+=k;
        x+=lowbit(x);
    }
}
int getsum(int x)
{
    int res=0;
    while(x>0)
    {
        res+=tree[x];
        x-=lowbit(x);
    }
    return res;
}
int query(int x,int l,int r)//查询第x大的数
{
    if(l==r) return l;
    int mid=(l+r)/2;
//    printf(" x=%d %d %d %d\n",x,l,r,getsum(mid));
    if(x>getsum(mid))
    {
        query(x,mid+1,r);
    }
    else
    {
        query(x,l,mid);
    }
}
int main()
{
    while(scanf("%d",&q)==1)
    {
        //init
        memset(a,0,sizeof a);
        memset(tree,0,sizeof tree);
        while(q--)
        {
           scanf("%d",&e);
           if(e==0)
           {
               scanf("%d",&x);
               a[x]++;
               update(x,1);
           }
           else if(e==1)
           {
               scanf("%d",&x);
               if(a[x]==0)
                    printf("No Elment!\n");
               else
                    a[x]--,update(x,-1);
           }
           else
           {
               scanf("%d%d",&l,&k);
               int num=getsum(l);
               if(num+k> getsum(maxn-1)) printf("Not Find!\n");
               else
               {
                   int res=query(k+num,1,maxn-1);
                   printf("%d\n",res);
               }
           }
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值