hdu2852(二分枚举+树状数组)

KiKi's K-Number

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2254    Accepted Submission(s): 1024


Problem Description
For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?
 

Input
Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container  

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.
 

Output
For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".
 

Sample Input
  
  
5 0 5 1 2 0 6 2 3 2 2 8 1 7 0 2 0 2 0 4 2 1 1 2 1 2 2 1 3 2 1 4
 

Sample Output
  
  
No Elment! 6 Not Find! 2 2 4 Not Find!
 

Source
 

Recommend
gaojie
        本题给定一个数的序列,然后给定若干操作(3种)。
                      0.表示插入一个数e
                      1.表示删除一个数e
                      2.表示询问比e大且是第k小数
         本来打算先读入所有操作,离散化处理。发现数据0 <e <100000, 0 <k <10000,想到可以直接e看做下表。对于0、1操作可以用树状数组解之。对于3操作,我们可以采用二分枚举。总的时间复杂度为O(M*log(N)*log(N)).
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN=100000+100;
int C[MAXN];
int Lowbit[MAXN];
//C[i] = a[i-lowbit(i)+1] + …+ a[i],下表从1开始
//Lowbit[i]=i&(i^(i-1));或Lowbit[i]=i&(-i); 
//1.查询
int QuerySum(int p)
	//查询原数组中下标1-p的元素的和 
{ 
	int nSum=0; 
	while(p>0) 
	{  
		nSum+=C[p]; 
		p-=Lowbit[p]; 
	} 
	return nSum; 
} 

//2.修改+初始化
void Modify(int p,int val) 
	//原数组中下表为p的元素+val,导致C[]数组中部分元素值的改变
{ 
	while(p<=MAXN-10) 
	{ 
		C[p]+=val; 
		p+=Lowbit[p]; 
	} 
} 
//************************************************************
int Binary_search(int l,int r,int k)
{
	int low,high,mid,tmp;
	low=l;high=r;tmp=QuerySum(l);
	while(low<=high)
	{
		mid=(low+high)>>1;
		if(QuerySum(mid)-tmp<k)
			low=mid+1;
		else high=mid-1;
	}
	return low;
}

int main()
{
	int n,op,a,b,i;
	for(i=1;i<MAXN;i++)
		Lowbit[i]=i&(-i);
	while(~scanf("%d",&n))
	{
		memset(C,0,sizeof(C));
		while(n--)
		{
			scanf("%d",&op);
			if(0==op)
			{
				scanf("%d",&a);
				a++;
				Modify(a,1);
			}
			else if(1==op)
			{
				scanf("%d",&a);
				a++;
				if(QuerySum(a)-QuerySum(a-1))
				{
					//printf("********succeed\n");
					Modify(a,-1);
				}
				else printf("No Elment!\n");
			}
			else 
			{
				scanf("%d%d",&a,&b);
				a++;
				if(QuerySum(MAXN-10)-QuerySum(a)<b)
					printf("Not Find!\n");
				else printf("%d\n",Binary_search(a,MAXN-10,b)-1);
			}
		}
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值