hdu 1075(字典树)

题目:

What Are You Talking About
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 19695 Accepted Submission(s): 6468
problem Description Ignatius is so lucky that he met a Martian
yesterday. But he didn’t know the language the Martians use. The
Martian gives him a history book of Mars and a dictionary when it
leaves. Now Ignatius want to translate the history book into English.
Can you help him?

Input The problem has only one test case, the test case consists of
two parts, the dictionary part and the book part. The dictionary part
starts with a single line contains a string “START”, this string
should be ignored, then some lines follow, each line contains two
strings, the first one is a word in English, the second one is the
corresponding word in Martian’s language. A line with a single string
“END” indicates the end of the directory part, and this string should
be ignored. The book part starts with a single line contains a string
“START”, this string should be ignored, then an article written in
Martian’s language. You should translate the article into English with
the dictionary. If you find the word in the dictionary you should
translate it and write the new word into your translation, if you
can’t find the word in the dictionary you do not have to translate it,
and just copy the old word to your translation. Space(’ ‘), tab(’\t’),
enter(’\n’) and all the punctuation should not be translated. A line
with a single string “END” indicates the end of the book part, and
that’s also the end of the input. All the words are in the lowercase,
and each word will contain at most 10 characters, and each line will
contain at most 3000 characters.

Output In this problem, you have to output the translation of the
history book.

Sample Input
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i’m fiwo riwosf. i fiiwj fnnvk! END
Sample Output
hello, i’m from mars. i like earth!

分析

可以用map,这里用字典树
数据结构分析:
在这里插入图片描述
然后主要就是insert函数和find函数,懂了原理也比较好理解
可以参考这篇:https://blog.csdn.net/qq_40733911/article/details/96857434

参考代码:


#include<bits/stdc++.h>         
using namespace std;
struct node
{
	int flag;
	char str[15];
	node *next[26];
	node()
	{
		flag=0;
		memset(str,0,sizeof(str));
		for(int i=0;i<26;i++)
			next[i]=NULL;
	}
}*trie,*p;
void insert(char *word1,char *word2)
{
	p=trie;
	for(int i=0;word1[i]!='\0';i++)
	{
		int t=word1[i]-'a';
		if(p->next[t]==NULL)
			p->next[t]=new node;
		p=p->next[t];
	}
	p->flag=1;
	strcpy(p->str,word2);
}
void find(char *word)
{
	p=trie;
	for(int i=0;word[i]!='\0';i++)
	{
		int t=word[i]-'a';
		if(p->next[t]!=NULL)
			p=p->next[t];		
		else
		{
			printf("%s",word);
			return ;
		}
	}
	if(p->flag==1)
		printf("%s",p->str);
	else
		printf("%s",word);
}
int main()
{
	char a[15],b[15],str[3005],t[15];
	trie=new node();
	scanf("%s",a);
	getchar();
	while(scanf("%s",a),strcmp(a,"END"))
	{
		scanf("%s",b);
		insert(b,a);
	}
	scanf("%s",a);
	getchar();
	while(gets(str),strcmp(str,"END"))
	{
		for(int i=0,k=0;str[i]!='\0';i++)
		{
			if(islower(str[i]))
				t[k++]=str[i];
			else
			{
				t[k]='\0';
				find(t);
				memset(t,0,sizeof(t));
				k=0;
				printf("%c",str[i]);
			}
		}
		printf("\n");
	}
	return 0;
}

总结:这个题是字典树使用的一个实际案例,字典树还有其他的方法这里未涉及到

参考博客:https://blog.csdn.net/liangzhaoyang1/article/details/51532802
https://blog.csdn.net/qq_40733911/article/details/96857434

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值