Problem G: STL——邮票

Problem G: STL——邮票

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 3924   Solved: 1873
[ Submit][ Status][ Web Board]

Description

小明是个邮票迷,整天乐衷于邮票收集。他对每张邮票都有一个喜爱程度,用一个正整数来表示,整数越大代表小明越喜欢这张邮票,小明经常购买邮票来丰富他的收藏。
有时候小明的朋友会来和小明要邮票,于是小明每次就给他最不喜欢的一张。这是个麻烦的工作,小明听说你最近学习了multiset,你能帮他解决吗?

Input

有多组输入数据,对于每个数据,有一个整数n(1<n<=20),接下来n行,每行只有以下两种格式之一:
“B S”,代表小明买了一张喜欢程度为S的邮票
“G” 代表小明的朋友问小明要邮票。
n=0代表输入结束。

Output

对于每次输入“G”,你要输出小明给了朋友邮票的喜好程度。

Sample Input

8B 20B 10GB 9GB 100B 25G0

Sample Output

10920

HINT

用STL的multiset容易解决


Append Code

[ Submit][ Status][ Web Board]
?
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
#include<iostream> 
#include<set> 
using namespace std; 
int main() 
     int n; 
    
     while (cin>>n&&n!=0) 
    
         multiset< int >s; 
         multiset< int >::iterator it; 
         while (n--) 
        
             char a; 
             cin>>a; 
             if (a== 'B'
            
                 int b; 
                 cin>>b; 
                 s.insert(b); 
            
             if (a== 'G'
            
               it=s.begin(); 
               cout<<*it<<endl; 
               s.erase(s.begin()); 
            
        
    
     return 0; 
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值