杭电1003——连续最大和

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.<br>

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).<br>

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.<br>

 

Sample Input

 

25 6 -1 5 4 -77 0 6 -1 1 -6 7 -5

Sample Output

 

Case 1:14 1 4Case 2:7 1 6

 

题目大意:求最大的连续字段和,求出并输出该子段和的起始位置。

开始错误的写法,借鉴~

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int t,n,a[100010];
    int s,i,start,endd,sum_max,sum;
    cin>>t;
       s=1;
        while(t--)
        {
            //cout<<"t的值是:"<<t<<endl;
            cin>>n;
            for(i=0; i<n; i++)
                cin>>a[i];
            start=1;
            sum_max=-9999;
            sum=0;


            for(i=0; i<n; i++)
            {
                sum+=a[i];
                if(sum>sum_max)
                {
                   sum_max=sum;
                    endd=i+1; //start没有在此生成
                }
                if(sum<0)
                {             //这里sum的值没有归零
                    start=i+2;
                }
            }


            cout<<"Case "<<s++<<":"<<endl;
            cout<<sum_max<<" "<<start<<" "<<endd<<endl;
            //cout<<"t的值是:"<<t<<endl;
            if(t>0)
            printf("\n");


        }
    }
start没有在此生成
                }
                if(sum<0)
                {             //这里sum的值没有归零
                    start=i+2;
                }
            }


            cout<<"Case "<<s++<<":"<<endl;
            cout<<sum_max<<" "<<start<<" "<<endd<<endl;
            //cout<<"t的值是:"<<t<<endl;
            if(t>0)
            printf("\n");


        }
    }

 

下面是正确的啦~~~

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int t,n,a[100010],k;
    int s,i,start,endd,sum_max,sum;
    cin>>t;
    s=1;
    while(t--)
    {
        cin>>n;
        for(i=0; i<n; i++)
            cin>>a[i];
        k=1; //中间变量k,用来记录start的变化
        sum_max=-9999;
        sum=0;
        for(i=0; i<n; i++)
        {
            sum+=a[i];
            if(sum>sum_max)
            {
                sum_max=sum;
                start=k;
                endd=i+1; //开始与截止的位置均在此处生成
            }
                if(sum<0)
                {
                    sum=0;
                    k=i+2; //中间变量k的设置
                }
        }

        cout<<"Case "<<s++<<":"<<endl;
        cout<<sum_max<<" "<<start<<" "<<endd<<endl;
        //cout<<"t的值是:"<<t<<endl;
        if(t>0)
            printf("\n");

    }
}

//开始与截止的位置均在此处生成
            }
                if(sum<0)
                {
                    sum=0;
                    k=i+2; //中间变量k的设置
                }
        }

        cout<<"Case "<<s++<<":"<<endl;
        cout<<sum_max<<" "<<start<<" "<<endd<<endl;
        //cout<<"t的值是:"<<t<<endl;
        if(t>0)
            printf("\n");

    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值