杭电 acm 1003 Max Sum(dp最大子序列)

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 278732    Accepted Submission(s): 66175


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
 
 
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
 
 
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
 

Recommend

We have carefully selected several similar problems for you:  1176 1069 1058 1159 1257 


#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std; 
int main()
{
    int n,m,a[100001],sum,MAX=0;
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		memset(a,0,sizeof(a));
		cin>>m;
		for(int j=1;j<=m;j++)
		{ 
		 cin>>a[j];
		} 
		sum=a[1],MAX=a[1];
		int x=1,y=1,z=1;
		 for(int j=2;j<=m;j++)
		 {
		 	if(sum+a[j]<a[j])
		 	{
		 		sum=a[j];
		 		z=j;
			 }
			 else
			 sum+=a[j];
			 if(sum>MAX)
			 {
			 	MAX=sum;
			 	y=j;
			 	x=z;
			 }
		 }
	  cout<<"Case "<<i<<":"<<endl;
	  cout<<MAX<<" "<<x<<" "<<y;
	  if(i!=n)
	  cout<<endl<<endl;
	  else
	  cout<<endl;
	}
	return 0;
 } 
开始用数组进行存数,超时,后来用MAX和SMALL分别存下起始相同结束不同的地方的数字段和以及起始不同结束相同的数字段最大和,再次超时,最终简化成了现在的这个样子。。。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值