Dice Possibility HihoCoder - 1339

What is possibility of rolling N dice and the sum of the numbers equals to M?

Input

Two integers N and M. (1 ≤ N ≤ 100, 1 ≤ M ≤ 600)

Output

Output the possibility in percentage with 2 decimal places.

Sample Input

2 10

Sample Output

8.33

思路:dp[i][j]表示前i个筛子得到的和为j的概率

dp[i][j]+=dp[i-1][k]*1.0/6;

代码:

#pragma comment(linker, "/STACK:1024000000,1024000000") //加栈
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
#include <set>
#include <string>
#include <math.h>
#include <stack>
using namespace std;
typedef long long ll;
const int maxn = 1e5+10;
#define inf 0x3f3f3f3f
double dp[200][1000];
int n,m;
int main(int argc, char const *argv[])
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=6;i++)
        {
            dp[1][i]=1.0/6;
        }
        for(int i=2;i<=n;i++)
        {
            for(int j=i;j<=m;j++)
            {
                for(int k=1;k<=6;k++)
                {
                    if(j-k>0)
                    {
                        dp[i][j]+=1.0*dp[i-1][j-k]/6;
                    }
                }
            }
        }
        printf("%.2lf\n",100*dp[n][m]);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值