我的笔记之A1001 A+B Format

Sample Input

-1000000 9

Sample Output

-999,991

思路

通过 insert()从后向前添加逗号

第一次提交:

错在逗号理解是从左到右三个一组,就很蠢,完全不符合实际
11998会被输出成119,98,这也太睿智了…明明就应该是从右往左三个一组,即11,998

第二次提交

int main(){
    int a,b;
    scanf("%d %d",&a,&b);
    int sum = a+b;
    string s = to_string(sum);
    string ans;
    if(abs(sum)<10000)  {printf("%d",sum);return 0;}
    if(sum<0){
        s.erase(s.begin());
        printf("-");
    }

    int len = s.length();

    for(int i=len-1;i>=0;i--){
        if((len-i)%3==0&&i!=0)
            s.insert(i,",");
    }
    cout<<s;
    return 0;   
}

第10个测试点过不去
错在题目没审清

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

题目上说是少于四位即三位及以下才不加逗号,我写的是四位也不加逗号,这就明显是题目没审清楚导致的!!!
真实考场上怎么办:再返回去重新读题目重新理解!以及最开始读题目的时候就不能马虎!
正解如下:

int main(){
    int a,b;
    scanf("%d %d",&a,&b);
    int sum = a+b;
    string s = to_string(sum);
    string ans;
    if(abs(sum)<1000)  {printf("%d",sum);return 0;}
    if(sum<0){
        s.erase(s.begin());
        printf("-");
    }

    int len = s.length();

    for(int i=len-1;i>=0;i--){
        if((len-i)%3==0&&i!=0)
            s.insert(i,",");
    }
    cout<<s;
    return 0;   
}

要积累的知识点

to_string()函数,可将intstring

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
可以使用面向对象的思想来构建“超市购物”程序。我们可以先定义两个类,一个是商品类,一个是购物者类。商品类中包含属性货物名、货号、价格和数量等信息,还包含获取货物名和价格的方法。购物者类中包含购物清单和购买商品等方法。在购物者类中先定义购物清单列表,再根据购买的商品名称查找商品的价格并计算出总价格。每次购买商品时,还需要统计相应商品的销售数量。 下面是一个示例代码: ```python class Commodity: def __init__(self, name, code, price, quantity): self.name = name self.code = code self.price = price self.quantity = quantity def get_name(self): return self.name def get_price(self): return self.price class Shopper: def __init__(self): self.shopping_list = [] # 初始化购物清单 def add_item(self, commodity, quantity): # 添加购买的商品和对应数量 self.shopping_list.append((commodity, quantity)) def print_receipt(self): # 打印购物清单和总价格 total_price = 0 for commodity, quantity in self.shopping_list: name = commodity.get_name() price = commodity.get_price() sub_total = price * quantity total_price += sub_total print(f"{name} x {quantity} = {sub_total}") print(f"Total price: {total_price}") # 统计销售数量 for commodity, quantity in self.shopping_list: commodity.quantity += quantity # 定义一些商品 commodity1 = Commodity("soap", "A1001", 10, 100) commodity2 = Commodity("pen", "A1002", 5, 200) # 创建购物者并购买商品 shopper = Shopper() shopper.add_item(commodity1, 2) shopper.add_item(commodity2, 3) # 打印购物清单并统计销售数量 shopper.print_receipt() print(commodity1.quantity) print(commodity2.quantity) ``` 运行结果: ``` soap x 2 = 20 pen x 3 = 15 Total price: 35 102 203 ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值