POJ3321--Apple Tree(dfs序+树状数组)

                                                      Apple Tree

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 37319 Accepted: 11138

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

 

 

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"C x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"Q x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

 

题意:给一棵树,n个节点,初始每个节点权值为1,m个操作,查询给定子树的所有节点权值之和,或者如果给定节点当前权值不为零,则将该节点权值变为零,否则变为1;

解法:DFS序+树状数组

如果还没接触过DFS序,推荐一篇大佬的博客:DFS序和欧拉序

我们知道DFS序中任一一颗子树的时间戳是一段连续的整数,所以先建立树的DFS序,然后需要支持单点修改和区间查询,可以用树状数组或者线段树;

另外注意用vector存图的话,用vector<int> vec[maxn]会TLE,需要用vector<vector<int> > vec(maxn);我也不知道是啥梗 :(

 

 

附代码:

#include<cstdio>
#include<vector>
#include<cstring>

using namespace std;

const double eps=1.0e-5;
const int maxn=100000+10;

int len=0,n,m,s[maxn],e[maxn],node,a,b; //s,e数组为DFS第一次访问时间和最后一次访问时间,即时间戳 
vector<vector<int> > vec(maxn);  
bool have[maxn];  //记录时间戳为i的节点是否有苹果; 
char c[10];

struct bit{   //树状数组 
	int sum[maxn];
	bit() {memset(sum,0,sizeof(sum));}
	int lowbit(int x) {return x&(-x);} 
	void add(int id,int val){
		for(int i=id;i<=n;i+=lowbit(i)){
			sum[i]+=val;
		}
	}
	int query(int id){
		int ans=0;
		for(int i=id;i>=1;i-=lowbit(i)){
			ans+=sum[i];
		}
		return ans;
	}
};

void dfs(int k,int pre)  //建立DFS序 
{
	s[k]=++len;
	for(int i=0;i<vec[k].size();i++) if(vec[k][i]!=pre) dfs(vec[k][i],k);
	e[k]=len;
}

void init(bit &tree)
{
	len=0;
	for(int i=1;i<=n;i++){
		have[i]=true;
		tree.add(i,1);
		vec[i].clear();
	}
}

int main()
{
	
	while(~scanf("%d",&n)){
		bit tree;
		init(tree);
		for(int i=1;i<=n-1;i++){
			scanf("%d %d",&a,&b);
			vec[a].push_back(b);
			vec[b].push_back(a);
		}
		dfs(1,1);
		
		scanf("%d",&m);
		for(int i=1;i<=m;i++){
			scanf("%s %d",c+1,&node);
			if(c[1]=='Q') printf("%d\n",tree.query(e[node])-tree.query(s[node]-1));
			else{
				tree.add(s[node],have[s[node]]?-1:1);
				have[s[node]]=!have[s[node]];
			}
		}
	}
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值