HDU1228A + B

本文章仅用于笔记。部分知识点来源于网络,授权请联系作者(947043511@qq.com)。


题目


读入两个小于100的正整数A和B,计算A+B. 
需要注意的是:A和B的每一位数字由对应的英文单词给出. 
Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出. 
Output
对每个测试用例输出1行,即A+B的值. 
Sample Input
one + two =
three four + five six =
zero seven + eight nine =
zero + zero =
Sample Output
3
90
96


解题


import java.util.Scanner;

public class HDU1228
{

	public static void main(String[] args)
	{
		Scanner s=new Scanner(System.in);
		while(s.hasNextLine())
		{
			String str=s.nextLine();
			str=str.replace("zero ", "0");
			str=str.replace("one ", "1").replace("two ", "2").replace("three ", "3");
			str=str.replace("four ", "4").replace("five ", "5").replace("six ", "6");
			str=str.replace("seven ", "7").replace("eight ", "8").replace("nine ", "9");
			int shu=0;
			//F一
			for(int i=0;i<str.length();i++)
			{
				char qu=str.charAt(i);
				if(qu>=48&&qu<=57)
				{
					char qu1=str.charAt(i+1);
					if(qu1>=48&&qu1<=57)
					{
						shu+=((qu-48)*10+qu1-48);
						i++;
					}
					else
						shu+=qu-48;
				}
			}
			/*F二
			int index=str.indexOf("+");
			int m=Integer.parseInt(str.substring(0,index));
			int n=Integer.parseInt(str.substring(index+2,str.length()-1));
			shu=m+n;
			*/
			if(shu==0)
				break;
			else
				System.out.println(shu);
		}
	}
}


求来波关注! 谢谢啦0.0!

小小小作者 
@Fanny0602


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值