hdu4965(矩阵快速幂)

One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her. 

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation. 

Step 1: Calculate a new N*N matrix C = A*B. 
Step 2: Calculate M = C^(N*N). 
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’. 
Step 4: Calculate the sum of all the elements in M’. 

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.

Input

The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B. 

The end of input is indicated by N = K = 0.

Output

For each case, output the sum of all the elements in M’ in a line.

Sample Input

4 2
5 5
4 4
5 4
0 0
4 2 5 5
1 3 1 5
6 3
1 2 3
0 3 0
2 3 4
4 3 2
2 5 5
0 5 0
3 4 5 1 1 0
5 3 2 3 3 2
3 1 5 4 5 2
0 0

Sample Output

14
56

题意:

给定一个A(n*k)矩阵和B(k*n)矩阵,其中k<=6,n<=1000。求(A*B)^(n*n)的各个元素对6取余后的和。

题意:

正常的A*B之后得到1000*1000的矩阵,在之后矩阵乘法中就会爆掉,所以需要改变下形式。(A*B)^(n*n)=A*(B*A)^(n*n-1)*B。其中B*A是一个6*6的矩阵,那么之后就可以用矩阵快速幂求得C=(B*A)^(n*n-1),接着求A*C*B即可。(注意一点数组一定要计算好不要开小了,自己开小了re了好几次)

代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long ll;
const int mod=6;
ll mmod=6;
ll s1[10009][100];
ll s2[100][10009];
ll s3[1009][1009];
ll s4[1009][1009];
struct mat
{
    int r,c;
    ll m[9][9];
    void clear()
    {
        for(int i=1; i<=r; i++)memset(m[i],0,sizeof(m[i]));
    }
};

int read()
{
    int x=0;
    char c=getchar();
    while(c>'9'||c<'0')c=getchar();
    while(c>='0'&&c<='9')
    {
        x=x*10+c-'0';
        c=getchar();
    }
    return x;
}

mat MatMul(mat &m1,mat &m2)
{
    mat tmp;
    tmp.r=m1.r;
    tmp.c=m2.c;
    int i,j,k;
    for(i=1; i<=tmp.r; i++)
    {
        for(j=1; j<=tmp.c; j++)
        {
            ll t=0;
            for(k=1; k<=m1.c; k++)
            {
                t=(t+(m1.m[i][k]*m2.m[k][j])%mmod)%mmod;
            }
            tmp.m[i][j]=t;
        }
    }
    return tmp;
}

mat MatQP(mat &a,int n)
{
    mat ans,tmp=a;
    ans.r=ans.c=a.r;
    memset(ans.m,0,sizeof(ans.m));
    for(int i=1; i<=ans.r; i++)
    {
        ans.m[i][i]=1;
    }
    while(n)
    {
        if(n&1)ans=MatMul(ans,tmp);
        n>>=1;
        tmp=MatMul(tmp,tmp);
    }
    return ans;
}

ll QP(ll a,ll n)   //快速幂。
{
    ll tmp=a,ans=1;
    while(n)
    {
        if(n&1)ans=ans*tmp%mod;
        tmp=tmp*tmp%mod;
        n>>=1;
    }
    return ans%mod;
}

int main()
{
    int n,k;

    while(~scanf("%d%d",&n,&k))
    {
        if(n==0)break;
        memset(s3,0,sizeof(s3));
        memset(s4,0,sizeof(s4));
        if(n==0)break;
        mat t;
        t.r=k;
        t.c=k;
        t.clear();
        ll x;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=k;j++)
            {
                cin>>s1[i][j];
            }
        }
        for(int i=1;i<=k;i++)
        {
            for(int j=1;j<=n;j++)
            {
               cin>>s2[i][j];
            }
        }

       for(int i=1;i<=k;i++)
       {
           for(int j=1;j<=k;j++)
           {
               for(int e=1;e<=n;e++)
               {
                   t.m[i][j]+=(s2[i][e]*s1[e][j]%6)%6;
               }
               t.m[i][j]%=6;
           }

       }
     mat tmp=MatQP(t,n*n-1);
     for(int i=1;i<=n;i++)
     {
         for(int j=1;j<=k;j++)
         {
             for(int e=1;e<=k;e++)
             {
                 s3[i][j]+=(s1[i][e]*tmp.m[e][j]%6)%6;;
             }
              s3[i][j]%=6;
         }

     }
     for(int i=1;i<=n;i++)
     {
         for(int j=1;j<=n;j++)
         {
             for(int e=1;e<=k;e++)
             {
                s4[i][j]+=(s3[i][e]*s2[e][j]%6)%6;
             }
               s4[i][j]%=6;
         }

     }
     ll sum=0;
     for(int i=1;i<=n;i++)
     {
         for(int j=1;j<=n;j++)
         {
             sum+=s4[i][j];
         }
     }
     cout<<sum<<endl;
    }
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值