hdu4965——Fast Matrix Calculation(快速矩阵幂优化)

Problem Description
One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her.

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation.

Step 1: Calculate a new N*N matrix C = A*B.
Step 2: Calculate M = C^(N*N).
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’.
Step 4: Calculate the sum of all the elements in M’.

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.

Input
The input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B.

The end of input is indicated by N = K = 0.

Output
For each case, output the sum of all the elements in M’ in a line.

Sample Input
4 2
5 5
4 4
5 4
0 0
4 2 5 5
1 3 1 5
6 3
1 2 3
0 3 0
2 3 4
4 3 2
2 5 5
0 5 0
3 4 5 1 1 0
5 3 2 3 3 2
3 1 5 4 5 2
0 0

Sample Output
14
56

看题目的时候至少注意了两点:
一是矩阵的规模有1000*1000,太大,而另一个数m太小,可疑
二是步骤写得太详细,不太可能直接跟着走就能过
然而我还是控制不住自己交了发上去爆栈了。。。。

题目是要求(A*B)^(N*N),其实就是A*B*A*B*A*B*A*B*A*B…,把中间的B*A提出来就成了A*(B*A)^(N*N-1)*B,而B*A是6*6的矩阵,运算时间一下降下来很多

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#define INF 0x3f3f3f3f
#define MAXN 10000005
#define Mod 10000007
using namespace std;
const int N = 10;
long long m,n;
struct Matrix
{
    int mat[N][N];
};
Matrix mul(Matrix a,Matrix b)
{
    Matrix res;
    for(int i=0; i<m; ++i)
        for(int j=0; j<m; ++j)
        {
            res.mat[i][j]=0;
            for(int k=0; k<m; ++k)
            {
                res.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
                res.mat[i][j]%=6;
            }
        }
    return res;
}
Matrix pow_matrix(Matrix a,long long k)
{
    Matrix res;
    memset(res.mat,0,sizeof(res.mat));
    for(int i=0; i<m; ++i)
        res.mat[i][i]=1;
    while(k!=0)
    {
        if(k%2)
            res=mul(res,a);
        a=mul(a,a);
        k>>=1;
    }
    return res;

}
int a[1005][1005],b[1005][1005],c1[1005][1005],c2[1005][1005];
int main()
{
    Matrix tmp;
    while(~scanf("%I64d%I64d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        memset(tmp.mat,0,sizeof(tmp.mat));
        for(int i=0; i<n; ++i)
            for(int j=0; j<m; ++j)
                scanf("%d",&a[i][j]);
        for(int i=0; i<m; ++i)
            for(int j=0; j<n; ++j)
                scanf("%d",&b[i][j]);
        for(int i=0; i<m; ++i)
            for(int j=0; j<m; ++j)
            {
                tmp.mat[i][j]=0;
                for(int k=0; k<n; ++k)
                {
                    tmp.mat[i][j]+=b[i][k]*a[k][j];
                    tmp.mat[i][j]%=6;
                }
            }
        Matrix p=pow_matrix(tmp,n*n-1);
        for(int i=0; i<n; ++i)
            for(int j=0; j<m; ++j)
            {
                c1[i][j]=0;
                for(int k=0; k<m; ++k)
                {
                    c1[i][j]+=a[i][k]*p.mat[k][j];
                    c1[i][j]%=6;
                }
            }
        for(int i=0; i<n; ++i)
            for(int j=0; j<n; ++j)
            {
                c2[i][j]=0;
                for(int k=0; k<m; ++k)
                {
                    c2[i][j]+=c1[i][k]*b[k][j];
                    c2[i][j]%=6;
                }
            }
        long long ans=0;
        for(int i=0; i<n; ++i)
            for(int j=0; j<n; ++j)
                ans+=c2[i][j];
        printf("%I64d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值