PTA 03-树2 List Leaves


03-树2 List Leaves(25 分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

#include <stdio.h>
#include <stdlib.h>
struct Tree {
 int data;
 int left;
 int right;
};
int main()
{
 int num,sum;
 sum = 0;
 int i;
 scanf("%d ", &num);
 for (i = 0; i < num; i++)
 {
  sum += i;
 }
 struct Tree * T;
 T = (struct Tree*)malloc(sizeof(struct Tree)*num);
 for (i = 0; i < num; i++)
 {
  T[i].data = i;
  int l, r;
  scanf("%c %c \n", &l,&r);

  if (l == 45) T[i].left = -1;
  else T[i].left = l-'0';
  if (r == 45) T[i].right = -1;
  else T[i].right = r-'0';
 }
 for (i = 0; i < num; i++)
 {
  printf("%d %d %d\n", T[i].data, T[i].left, T[i].right);
 }
 return 0;
}


目前问题:在全部输入后还需再次输入一个任意值程序方能正常进行。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值