03-树2 List Leaves (25分)

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer NN (\le 10≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N-1N−1. Then NN lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a “-” will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves’ indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:

4 1 5

思路:这道题跟上道题二叉树的构建类似,不同的是这个题节点的数据就是它在数组中的下标,很明显必须采用层次遍历的方式才能从上到下从左到右输出叶子节点。这里采用队列的方式实现层次遍历。

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<queue>
using namespace std;
#define MaxTree 10
#define Null -1
typedef int Tree;
struct TreeNode{
    Tree Left;
    Tree Right;
}T[MaxTree];
int N,check[MaxTree]={0},count=0;
queue<int> q;

Tree BuildTree(struct TreeNode T[]){
    Tree Root=Null;
    int i;
    char cl,cr;
    scanf("%d",&N);
    if(N){
        for(i=0;i<N;i++){
            scanf("\n%c %c",&cl,&cr);
            if(cl!='-'){
                T[i].Left=cl-'0';
                check[T[i].Left]=1;
            }
            else T[i].Left=Null;
            if(cr!='-'){
                T[i].Right=cr-'0';
                check[T[i].Right]=1;
            }
            else T[i].Right=Null;
        }   
        for(i=0;i<N;i++)
            if(check[i]==0) break;
        Root=i;
    }
    return Root;
}

void countleaves(Tree Root){        //每碰到一个节点将它的左右孩子入队(若有的话),然后依次从队头取出判断是否为叶子节点
    Tree temp;
    if(Root==Null)  return;
    q.push(Root);               
    while(!q.empty()){
        temp=q.front();
        q.pop();
        if(T[temp].Left==Null&&T[temp].Right==Null){    //如果没有左右孩子即为叶子节点,则输出
            if(count++!=0){     //不是第一个节点的话前面输出空格
                putchar(' ');
            }
            printf("%d",temp);          
        }
        if(T[temp].Left!=Null)      q.push(T[temp].Left);
        if(T[temp].Right!=Null)     q.push(T[temp].Right);
    }
}
int main(){
    Tree R;
    R=BuildTree(T);
    countleaves(R);
    return 0;
}
  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值