Octal Fractions

Octal Fractions


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Fractions in octal (base 8) notation can be expressed exactly in decimal notation. For example, 0.75 in octal is 0.963125 (7/8 + 5/64) in decimal. All octal numbers of n digits to the right of the octal point can be expressed in no more than 3n decimal digits to the right of the decimal point.

Write a program to convert octal numerals between 0 and 1, inclusive, into equivalent decimal numerals. The input to your program will consist of octal numbers, one per line, to be converted. Each input number has the form 0.d1d2d3 ... dk, where the di are octal digits (0..7). There is no limit on k. Your output will consist of a sequence of lines of the form

0.d1d2d3 ... dk [8] = 0.D1D2D3 ... Dm [10]

where the left side is the input (in octal), and the right hand side the decimal (base 10) equivalent. There must be no trailing zeros, i.e. Dm is not equal to 0.


SAMPLE INPUT

0.75
0.0001
0.01234567


SAMPLE OUTPUT

0.75 [8] = 0.953125 [10]
0.0001 [8] = 0.000244140625 [10]
0.01234567 [8] = 0.020408093929290771484375 [10]


Source: South Africa 2001

Submit    Status


Copyright @ 2001-2018, Zhejiang University ACM/ICPC Team, All rights reserved.

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=86 

模拟除法运算:从8进制的最低位开始除以8,加上他的上一位。

0.75 5/8 = 0.625

(0.625 + 7)/8  = 0.93125

真正运算的时候不带小数算

75 

5/8 625 

7625/8 93125

是这样的,最后输出的时候加上小数点即可。

#include<cstdio>
#include<cstring>
const int MaxN = 1001;
int main()
{
	int i, j;
	char src[MaxN];
	while (scanf("%s", src) != EOF)
	{
		char dest[MaxN] = {'0'};
		int index = 0;//十进制的位数
		for (i=strlen(src)-1;i>1;i--)
		{
			int num = src[i] - '0';
			int temp;
			//当前位数没有除尽或者还有余数的的时候
			for (j=0;j < index || num;j++)
			{
				temp = num * 10 + (j < index ? (dest[j] - '0') : 0);
				dest[j] = temp / 8 + '0';
				num = temp % 8;
			}
			index = j;//更新当前位数
		}
		printf("%s [8] = 0.%s [10]\n", src, dest);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

江湖无为

感谢你们的鼓励

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值