【PAT A1006 Sign In and Sign Out】

【PAT A1006 Sign In and Sign Out】


Question Description

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the 
last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find 
the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a 
positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time	
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door 	
on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign 
out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

Reference Code

#include<cstdio>
struct Sign_In {
int In_HH, In_MM, In_SS,
	Out_HH,Out_MM,Out_SS;
char ID[15];
}p,p0,pa,pb;//p输入 p0初始化 pa pb 最早签入 最晚签出

bool compare_In(Sign_In a,Sign_In b) {					//比较得出最早签入
if (a.In_HH != b.In_HH)return a.In_HH < b.In_HH;
else if (a.In_MM != b.In_MM)return a.In_MM < b.In_MM;
else return a.In_SS < b.In_SS;
	}
bool compare_Out(Sign_In a, Sign_In b) {				//比较得出最晚签出
if (a.Out_HH != b.Out_HH)return a.Out_HH > b.Out_HH;
else if (a.Out_MM != b.Out_MM)return a.Out_MM > b.Out_MM;
else return a.Out_SS > b.Out_SS;
}
void in()
{
pb.Out_HH = 00;			//最早签出
pb.Out_MM = 00;
pb.Out_SS = 00;
pa.In_HH = 23;			//最晚签入
pa.In_MM = 59;
pa.In_SS = 59;
}
int main() {
int N;
scanf("%d", &N);
in();
for (int i = 0; i < N; i++) {
	scanf("%s %d:%d:%d %d:%d:%d", &p.ID, &p.In_HH, &p.In_MM, &p.In_SS,
		&p.Out_HH, &p.Out_MM, &p.Out_SS);
	if(compare_In(p, pa))
				pa = p;
	if (compare_Out(p,pb))
				pb = p;
}
printf("%s %s", pa.ID, pb.ID);
return 0;
}

Operation Result

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值