PAT A1006 Sign In and Sign Out (25分)

75 篇文章 0 订阅

PAT A1006 Sign In and Sign Out (25分)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133

以下是AC的代码:

#include<cstdio>
#define maxn 100100
#define len 17
typedef struct{
	char name[len];
	int timein,timeout;
}record;
record recs[maxn];
int main(void){
	int total;
	int early=0,late=0;
	scanf("%d",&total);
	for(int i=0;i<total;i++){
		int hh,mm,ss;
		scanf("%s %d:%d:%d",&recs[i].name,&hh,&mm,&ss);
		recs[i].timein=hh*10000+mm*100+ss;
		scanf("%d:%d:%d",&hh,&mm,&ss);
		recs[i].timeout=hh*10000+mm*100+ss;
		if(recs[i].timein<recs[early].timein)early=i;
		if(recs[i].timeout>recs[late].timeout)late=i;
	}
	printf("%s %s",recs[early].name,recs[late].name);
	return 0;
}

思路:
用结构体数组存储数据,每次扫入数据的同时更新最早,最晚值,最后输出最早最晚标记所在节点的name值即可。
看了答案以后发现一个事实:C语言在同一行里可以写多个赋值语句,用逗号隔开,不会报错!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值