【PAT A1036】Boys VS Girls
Question Description
This time you are asked to tell the difference between the lowest grade of all the male students and the
highest grade of all the female students.
Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of
student information. Each line contains a student's name, gender, ID and grade, separated by a space,
where name and ID are strings of no more than 10 characters with no space, gender is either F (female)
or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.
Output Specification:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the
highest grade, and the second line gives that of the male student with the lowest grade. The third line
gives the difference grade F −grade M . If one such kind of student is missing, output Absent in the
corresponding line, and output NA in the third line instead.
Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA
Reference Code
#include<cstdio>
struct student {
char ID[30]; //id
char Name[15]; //学生姓名
char Gender; //学生性别 F female M man
int Grade; //成绩 [0,100]
}temp,F_Max_Grade,M_Min_Grade; //临时变量 成绩最高女同学者 成绩最低男同学者
void in() {
F_Max_Grade.Grade = -1;
M_Min_Grade.Grade = 101;
F_Max_Grade.Gender = 'F';
M_Min_Grade.Gender = 'M';
}
int main() {
int N; //输入人次
int M_count=0, F_count = 0;
scanf("%d", &N);
in();
while (N--){
scanf("");
scanf("%s %c %s %d", &temp.Name, &temp.Gender, &temp.ID, &temp.Grade);
if ((temp.Gender == 'F') && (temp.Grade > F_Max_Grade.Grade)) {
F_Max_Grade = temp; F_count++;
}
if ((temp.Gender == 'M') && (temp.Grade < M_Min_Grade.Grade)) {
M_Min_Grade = temp; M_count++;
}
}
if(F_count && M_count){
printf("%s %s\n%s %s\n%d", F_Max_Grade.Name, F_Max_Grade.ID, M_Min_Grade.Name, M_Min_Grade.ID,F_Max_Grade.Grade-M_Min_Grade.Grade);
}
else if (!F_count && M_count) {
printf("xAbsent\n%s %s\nNA", M_Min_Grade.Name, M_Min_Grade.ID);
}
else
//if (F_count && !M_count)
{
printf("%s %s\nAbsent\nNA", F_Max_Grade.Name, F_Max_Grade.ID);
}
return 0;
}
Operation Result