PAT A 甲级 1036 Boys vs Girls (25分)

1036 Boys vs Girls (25分)

吐槽

英语不够好又不好好看题的结果就是把Absent错当成了表示“有缺失”的而不是“该行缺失”的。顺带一提这么一说的话测点2(第3个测点)应该是没有男生。

逻辑

用两个vector分别保存男生和女生的数据,然后用两个不同的cmp函数sort然后输出front即可。、

题目

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade
​F
​​ −grade
​M
​​ . If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:
Mary EE990830
Joe Math990112
6

Sample Input 2:
1
Jean M AA980920 60

Sample Output 2:
Absent
Jean AA980920
NA

代码

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>

using namespace std;

typedef struct
{
	string name;
	string ID;
	int grade;
}stu;

bool cmp1(stu s1, stu s2)
{
	if (s1.grade < s2.grade)
		return true;
	else
		return false;
}

bool cmp2(stu s1, stu s2)
{
	if (s1.grade > s2.grade)
		return true;
	else
		return false;
}

int main()
{
	int m;
	cin >> m;
	int i;
	vector<stu> male;
	vector<stu> female;
	stu temp;
	string temps;
	for (i = 0; i < m; i++)
	{
		cin >> temp.name >> temps >> temp.ID >> temp.grade;
		if (temps == "M")
			male.push_back(temp);
		else if (temps == "F")
			female.push_back(temp);
	}
	sort(male.begin(), male.end(), cmp1);
	sort(female.begin(), female.end(), cmp2);
	if (male.empty() || female.empty())
	{
		if (!male.empty())
			cout << "Absent" << endl << male.front().name << " " << male.front().ID << endl;
		else if (!female.empty())
			cout << female.front().name << " " << female.front().ID << endl << "Absent" << endl;
		cout << "NA";
	}
	else
	{
		cout << female.front().name << " " << female.front().ID << endl;
		cout << male.front().name << " " << male.front().ID << endl;
		cout << female.front().grade - male.front().grade;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值