1093 字符串A+B

给定两个字符串 A 和 B,本题要求你输出 A+B,即两个字符串的并集。要求先输出 A,再输出 B,但重复的字符必须被剔除

输入格式:

输入在两行中分别给出 A 和 B,均为长度不超过 10​6​​的、由可见 ASCII 字符 (即码值为32~126)和空格组成的、由回车标识结束的非空字符串。

输出格式:

在一行中输出题面要求的 A 和 B 的和。

输入样例:

This is a sample test
to show you_How it works

输出样例:

This ampletowyu_Hrk

总结:

可以利用字符串的查找、或者定义额外的字符数组进行已有字符的判断,筛去已有字符。

代码:

第一种:利用字符串的查找。

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
#include <set>

using namespace std;

int main()
{
	string textStr[2], result;
	getline(cin, textStr[0]);
	getline(cin, textStr[1]);
		
	for(int j=0;j<2;j++) {
		for(int i=0;i<textStr[j].length();i++) {
			if( result.find(textStr[j][i]) == string::npos )
				result += textStr[j][i];
		}
	}
	
	cout << result << endl;
				
	return 0;
}

 第二种:利用数组对已存储的字符进行筛选。

#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
#include <set>

using namespace std;

int main()
{
	string textStr[2], result;
	getline(cin, textStr[0]);
	getline(cin, textStr[1]);
		
	bool textChar[200] = {0};
	for(int j=0;j<2;j++) {
		for(int i=0;i<textStr[j].length();i++) {
			if( textChar[ textStr[j][i] ] == false ) {
				result += textStr[j][i];
				textChar[ textStr[j][i] ] = true;
			}
		}
	}
	
	cout << result << endl;
				
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值