区域赛系列一多边形划分(卡塔兰数列)

描述

Give you a convex(凸边形), diagonal n-3 disjoint divided into n-2 triangles(直线), for different number of methods, such as n=5, there are 5 kinds of partition method, as shown in Figure

 

输入

The first line of the input is a n (1<=n<=1000), expressed n data set.
The next n lines each behavior an integer m (3<=m<=18), namely the convex edges.

输出

For each give m,, output how many classification methods.
example output: Case #a : b

样例输入

3
3
4
5

样例输出

Case #1 : 1
Case #2 : 2
Case #3 : 5
 前几项为 (OEIS中的数列A000108): 1, 1, 2, 5, 14, 42, 132, 429, 1430, 4862, 16796, 
58786, 208012, 742900, 2674440, 9694845, 35357670, 129644790, 477638700, 1767263190
, 6564120420, 24466267020, 91482563640, 343059613650, 1289904147324, 4861946401452,
令h(0)=1,h(1)=1,catalan数满足递归式:
h(n)= h(0)*h(n-1) + h(1)*h(n-2) +  + h(n-1)h(0) (其中n>=2)

另类递归式:  h(n)=((4*n-2)/(n+1))*h(n-1);

 

//卡卡特兰数
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef long long ll;
ll ktl[20];
int main()
{
	ktl[0] = 1;
	ktl[1] = 1;
	ktl[2] = 2;
	for (int i=3;i<=18;i++)
	{
		ll sum = 0,j = 1;
		while (j<=i)
		{
			sum += ktl[i-j] * ktl[j-1];
			j++;
		}
		ktl[i] = sum;
	}
	int t,k,n;
	scanf("%d",&t);
	for (k=1;k<=t;k++)
	{
		scanf("%d",&n);
		printf("Case #%d : %lld\n",k,ktl[n-2]);
	}
	return 0;
}
        

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值