Tickets

You have won a collection of tickets on luxury cruisers. Each ticket can be used only once, but can be used in either direction between the 2 different cities printed on the ticket. Your prize gives you free airfare to any city to start your cruising, and free airfare back home from wherever you finish your cruising.

You love to sail and don't want to waste any of your free tickets. How many additional tickets would you have to buy so that your cruise can use all of your tickets?

Now giving the free tickets you have won. Please compute the smallest number of additional tickets that can be purchased to allow you to use all of your free tickets.

Input

There is one integer T (T≤100) in the first line of the input.

Then T cases, for any case, the first line contains 2 integers n, m (1≤n, m≤100,000). n indicates the identifier of the cities are between 1 and n, inclusive. m indicates the tickets you have won.

Then following m lines, each line contains two integers u and v (1≤u, v≤n), indicates the 2 cities printed on your tickets, respectively.

Output

For each test case, output an integer in a single line, indicates the smallest number of additional tickets you need to buy.

Sample Input

3
5 3
1 3
1 2
4 5
6 5
1 3
1 2
1 6
1 5
1 4
3 2
1 2
1 2

Sample Output

1
2
0

       需要用完所有的票,完成巡游,另外要买的票来填补路线空缺,这样只能留下最多两个奇度数数顶点作为起点终点(可以是同一点),也就是欧拉路径。只需要找出记录度数是奇数点个数(偶数个)-2,然后每两个多余的点,买一张票连接。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int a[100010];//用来存每个点的度数 

int main()
{
	int t;
	scanf("%d",&t);
	while (t--)
	{
		int n,m,x,y;
		memset(a,0,sizeof(a));
		scanf("%d %d",&n,&m);
		for (int i=0;i<m;i++)
		{
			scanf("%d %d",&x,&y);
			a[x]++;
			a[y]++;
		}
		int cnt = 0;
		for (int i=1;i<=n;i++)
		{
			if (a[i]%2==1)
			{
				cnt++;
			}
		}
		int ans = (cnt-2) / 2;
		printf("%d\n",ans<0 ? 0 : ans);
	}
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值