1130 Infix Expression (25 分)

该博客介绍如何从给定的二叉语法树生成中缀表达式,考虑运算符的优先级,并提供了输入输出规格及示例。内容包括中序遍历策略,确保正确使用括号来体现运算符的优先级。
摘要由CSDN通过智能技术生成

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPGinfix2.JPG
Figure 1Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

题目大意:

                 给定一棵二叉树,输出相应的中缀表达式,括号反映运算符优先级

                 precedences 优先级   infix 中缀  parentheses 括号 

思路:

                 用静态方法建立一棵二叉树,并建立bool类型数组找根节点

                 中序遍历,如果不是根节点或是叶节点,那么遍历其左子树加上(,遍历其右子树加上)。

                 要知道不可能出现只有左孩子的节点。

 

#include<iostream>
#include<string>
using namespace std;
struct Node
{
	string data;
	int lchild,rchild;
}node[100];
bool vis[100]={false};
void inorder(int root,int deep)
{
	if(root==-1)
	return;
	else
	{
		if(node[root].rchild!=-1&&deep>1)
		printf("(");
		inorder(node[root].lchild,deep+1);
		printf("%s",node[root].data.c_str());
		inorder(node[root].rchild,deep+1);
		if(node[root].rchild!=-1&&deep>1)
		printf(")");
	}
}
int main()
{
	int n;
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{
		//scanf("%s %d %d",node[i].data,&node[i].lchild,&node[i].rchild);
		cin>>node[i].data>>node[i].lchild>>node[i].rchild;
		if(node[i].lchild!=-1)
		vis[node[i].lchild]=true;
		if(node[i].rchild!=-1)
		vis[node[i].rchild]=true;
	}
	int root;
	for(int i=1;i<=n;i++)
	{
		if(!vis[i])
		{
			root=i;
			break;
		}
	}
	//cout<<root<<endl;
	inorder(root,1);
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值