1155 Heap Paths (30 分) 有关堆的题

1155 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

题意:

         给你一棵完全二叉树的层序遍历,即可以得到一个堆,需要你从右子树开始镜像的输出从根到叶,并判断是大顶堆还是小顶堆还是不是堆

思路:

        dfs生成堆,并注意到达叶子结点的标志

              完全二叉树判断某个结点是否为叶子结点的标志是该节点root的左子节点的编号root*2是否大于结点总个数 n

       中间利用几个bool变量来判断是什么堆   (注意堆的根节点的数组下标一定要从1开始)

#include<iostream>
#include<vector>
using namespace std;
const int maxn=1005;
bool max_flag=false,min_flag=false,not_flag=false;
int level[maxn];
vector<int>path;	
int n;

void dfs(int root)
{
	path.push_back(level[root]);
	if(root*2>n)//表示该结点为叶子结点
	{
		for(int i=0;i<path.size();i++)
		{
			printf("%d",path[i]);
			if(i>0)
			{
				if(path[i]<=path[i-1])
				max_flag=true;
				else if(path[i]>=path[i-1])
				min_flag=true;
				if(min_flag==true&&max_flag==true)
				not_flag=true;
			}
			if(i<path.size()-1)
			printf(" ");
			else
			printf("\n");
		}
	} 
	else
	{
		if(root*2+1<=n)//右子树先 
		dfs(root*2+1);
		if(root*2<=n)//再左子树 
		dfs(root*2);
	}
	path.pop_back();
} 
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	{//注意这里要从1开始 
		scanf("%d",&level[i]);
	}
	dfs(1);//1号位进入 
	if(not_flag)
	printf("Not Heap\n");
	else
	{
		if(max_flag)
		printf("Max Heap\n");
		else if(min_flag)
		printf("Min Heap\n");	
	}	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
在C语言中,可以使用set来实现大根和小根。大根是指根节点的值大于等于其子节点的值,而小根是指根节点的值小于等于其子节点的值。 引用中给出了使用priority_queue实现大根和小根的示例代码。其中,priority_queue<int> maxHeap;表示定义了一个大根,而priority_queue<int, vector<int>, greater<int>> minHeap;则表示定义了一个小根。如果要使用自定义的结构体或类作为元素,需要重载<运算符来定义的顺序。 引用中的代码示例展示了使用deque来实现的功能。其中,使用dfs函数遍历树的节点,并根据节点的值来判断是插入1还是-1到unordered_set<int> record中,以判断是大根还是小根。 因此,在C语言中,可以使用set来实现大根和小根的功能。123 #### 引用[.reference_title] - *1* [c++大根小根](https://blog.csdn.net/qq_44289340/article/details/125861694)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT3_1"}} ] [.reference_item] - *2* *3* [PAT_甲级_1155 Heap Paths (30point(s)) (C++)【DFS/大根、小根判断】](https://blog.csdn.net/qq_41528502/article/details/105289948)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v92^chatsearchT3_1"}} ] [.reference_item] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值