2018年冬季PAT甲级考试 7-4 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

思路:判断大小堆很容易,关键是输出根节点到叶子结点的路径.采用DFS,在考场上改了好久,总觉得我的DFS写的还不够简洁明了。。。。

程序:

#include <cstdio>
#include <vector>
using namespace std;
int a[1005];
vector<int> v;
int n;
bool isMaxHeap(int n)
{
	for(int i = 1; i <= n / 2; i++)
	{
		if(a[i] < a[2*i])
		  return false;
		if(2*i+1 <= n && a[i] < a[2*i+1])
		  return false;
	}
	return true;
}
bool isMinHeap(int n)
{
	for(int i = 1; i <= n / 2; i++)
	{
		if(a[i] > a[2*i])  return false;
		if(2*i+1 <= n && a[i] > a[2*i+1]) return false;
	}
	return true;
}
void dfs(int s)
{
	if(s*2 > n)
	{
		
		printf("%d",a[1]);
		for(int i = 0; i < v.size(); i++)
	    {
		     printf(" %d",v[i]);
	    }
	    printf("\n");	
		return;
	}
	for(int i = s*2+1; i-1 <= n && i >= s*2; i--)
	{
	    if(i > n) continue;
	   	v.push_back(a[i]);
	    dfs(i);
	    v.pop_back();
	}
}
int main()
{
	scanf("%d",&n);
	for(int i = 1; i <= n; i++)
	{
		scanf("%d",&a[i]);
	}
	dfs(1);
	if(isMaxHeap(n))
      printf("Max Heap\n");
    else if(isMinHeap(n))
      printf("Min Heap\n");
    else
      printf("Not Heap\n");
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值