1115 Counting Nodes in a BST (30 分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than or equal to the node's key.
- The right subtree of a node contains only nodes with keys greater than the node's key.
- Both the left and right subtrees must also be binary search trees.
Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−10001000]which are supposed to be inserted into an initially empty binary search tree.
Output Specification:
For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:
n1 + n2 = n
where n1
is the number of nodes in the lowest level, n2
is that of the level above, and n
is the sum.
Sample Input:
9
25 30 42 16 20 20 35 -5 28
Sample Output:
2 + 4 = 6
题意:
建一棵二叉排序树,并求最后两层总的节点和
思路:
对于建树有些细节还不够理解 node *root=new root这句并没有完全理解
每层结点个数可以用数组来存储
//输出最低两层共有多少个结点
#include<iostream>
#include<vector>
using namespace std;
const int maxn=1005;
struct node
{
int data;
node *lchild,*rchild;
};
//二叉查找树的创建
node *build(node *root,int data)
{//到达空结点时即为要插入的位置
if(root==NULL)
{
root=new node; //node *root=new node;
root->data=data;
root->lchild=NULL;
root->rchild=NULL;
}
else if(data<=root->data)
root->lchild=build(root->lchild,data);
else
root->rchild=build(root->rchild,data);
return root;
}
int maxdeep=0;
//vector<int> num(1000);
int num[maxn];
void dfs(node *root,int deep)
{
if(root==NULL)
{
maxdeep=max(deep,maxdeep);
return;
}
num[deep]++;
dfs(root->lchild,deep+1);
dfs(root->rchild,deep+1);
}
int main()
{
int n;
scanf("%d",&n);
int xx;
node *root=NULL;//node *root=new node又是错的?
for(int i=0;i<n;i++)
{
scanf("%d",&xx);
root=build(root,xx);
}
dfs(root,0);
printf("%d + %d = %d\n",num[maxdeep-1],num[maxdeep-2],num[maxdeep-1]+num[maxdeep-2]);
}